Debugger

Managed Debugger (by David Srbecky)

Debugger Namespace

This library provides features for debugging managed applications.

Namespace hierarchy

Classes

Class | Description
ArrayElement | Represents an element of an array
Breakpoint |
BreakpointEventArgs |
CannotGetValueException |
DebugeeState | Unique identifier of the state of the debugee. Changes when debuggee is stepped, but not when properity is evaluated.
DebuggerEventArgs |
DebuggerException |
DebuggerObject | A base class for all classes declared by the debugger
DebugType | Represents a type in a debugee. That is, a class, array, value type or a primitive type. This class mimics the Type class.
Eval | This class holds information about function evaluation.
EvalEventArgs | Provides data related to evalution events
Exception |
ExceptionEventArgs |
FieldInfo | Provides information about a field of some class.
Function | A function (or also a method or frame) which is being executed on some thread. Use to obtain arguments or local variables.
LocalVariable | Represents a local variable in a function
MemberInfo | Provides information about a member of some class (eg. a field or a method).
MemberValue | Represents a member of class or value type - that is, a field or a property
MessageEventArgs |
MethodArgument | Represents an argument of a function. That is, it refers to the runtime value of function parameter.
MethodInfo | Provides information about a method in a class
Module |
ModuleEventArgs |
NamedValue | NamedValue is a Value which has some name associated with it - eg the name of the field that holds the value.
NamedValueCollection | An enumerable collection of values accessible by name.
NDebugger |
PauseSession | Holds information about the state of paused debugger. Expires when when Continue is called on debugger.
Process |
ProcessEventArgs |
PropertyInfo | Provides information about a property in a class
SourcecodeSegment |
Stepper |
StepperEventArgs |
Thread |
ThreadEventArgs |
Value | Provides more specific access
ValueEventArgs | Provides data for events related to Value class

Interfaces

Interface | Description
IExpirable |
IMutable |

Enumerations

Enumeration | Description
BindingFlags | Binding flags specify which members should be returned. Use 'or' operation to combine flags.
EvalState |
ExceptionType |
PausedReason |
Stepper.StepperOperation |

Send comments on this topic.


ArrayElement Class

Represents an element of an array

For a list of all members of this type, see ArrayElement Members.

System.Object
MarshalByRefObject
DebuggerObject
Value
NamedValue
ArrayElement

public class ArrayElement : NamedValue

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

ArrayElement Members | Debugger Namespace


ArrayElement Members

ArrayElement overview

Public Instance Properties

ArrayDimensions (inherited from Value) | Gets the lengths of individual dimensions. eg new object[4,5] returns {4,5};
ArrayLenght (inherited from Value) | Gets the number of elements the array can store. eg new object[4,5] returns 20
ArrayRank (inherited from Value) | Gets the number of dimensions of the array. eg new object[4,5] returns 2
AsString (inherited from Value) | Gets a string representation of the value
HasExpired (inherited from Value) | Returns true if the Value have expired and can not be used anymore
Indicies | The indicies of the element; one for each dimension of the array.
IsArray (inherited from Value) | Returns true if the value is an array
IsInteger (inherited from Value) | Gets a value indicating whether the type is an integer type
IsNull (inherited from Value) | Returns true if the value is null
IsObject (inherited from Value) | Returns true if the value is a class or value type
IsPrimitive (inherited from Value) | Returns true if the value is an primitive type. eg int, bool, string
Name (inherited from NamedValue) | Gets the name associated with the value
PrimitiveValue (inherited from Value) | Gets or sets the value of a primitive type. If setting of a value fails, NotSupportedException is thrown.
Process (inherited from Value) | The process that owns the value
Type (inherited from Value) | Returns the DebugType of the value

Public Instance Methods

GetArrayElement (inherited from Value) | Overloaded. Returns an element of a single-dimensional array
GetArrayElements (inherited from Value) | Returns all elements in the array
GetMember (inherited from Value) | Get a field or property of an object with a given name.
GetMembers (inherited from Value) | Overloaded. Get all fields and properties of an object.
SetValue (inherited from Value) | Copy the acutal value from some other Value object

Public Instance Events

Changed (inherited from Value) | Occurs when the Value have potentialy changed
Expired (inherited from Value) | Occurs when the Value can not be used anymore

Protected Instance Methods

OnChanged (inherited from Value) | Is called when the value changes
OnExpired (inherited from Value) | Is called when the value expires and can not be used anymore

See Also

ArrayElement Class | Debugger Namespace


ArrayElement Properties

The properties of the ArrayElement class are listed below. For a complete list of ArrayElement class members, see the ArrayElement Members topic.

Public Instance Properties

ArrayDimensions (inherited from Value) | Gets the lengths of individual dimensions. eg new object[4,5] returns {4,5};
ArrayLenght (inherited from Value) | Gets the number of elements the array can store. eg new object[4,5] returns 20
ArrayRank (inherited from Value) | Gets the number of dimensions of the array. eg new object[4,5] returns 2
AsString (inherited from Value) | Gets a string representation of the value
HasExpired (inherited from Value) | Returns true if the Value have expired and can not be used anymore
Indicies | The indicies of the element; one for each dimension of the array.
IsArray (inherited from Value) | Returns true if the value is an array
IsInteger (inherited from Value) | Gets a value indicating whether the type is an integer type
IsNull (inherited from Value) | Returns true if the value is null
IsObject (inherited from Value) | Returns true if the value is a class or value type
IsPrimitive (inherited from Value) | Returns true if the value is an primitive type. eg int, bool, string
Name (inherited from NamedValue) | Gets the name associated with the value
PrimitiveValue (inherited from Value) | Gets or sets the value of a primitive type. If setting of a value fails, NotSupportedException is thrown.
Process (inherited from Value) | The process that owns the value
Type (inherited from Value) | Returns the DebugType of the value

See Also

ArrayElement Class | Debugger Namespace


Indicies Property

Managed Debugger (by David Srbecky)

ArrayElement.Indicies Property

The indicies of the element; one for each dimension of the array.

public UInt32[] Indicies {get;}

See Also

ArrayElement Class | Debugger Namespace


BindingFlags Enumeration

Binding flags specify which members should be returned.

Use 'or' operation to combine flags.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum BindingFlags

Members

Member Name | Description | Value
Instance |  | 1
Static |  | 2
Public |  | 4
NonPublic |  | 8
All |  | 15

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Debugger Namespace


Breakpoint Class

For a list of all members of this type, see Breakpoint Members.

System.Object
MarshalByRefObject
DebuggerObject
Breakpoint

public class Breakpoint : DebuggerObject

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Breakpoint Members | Debugger Namespace


Breakpoint Members

Breakpoint overview

Public Instance Properties

Debugger
Enabled
HadBeenSet
SourcecodeSegment

Public Instance Methods

Equals
GetHashCode
SetBreakpoint

Public Instance Events

Changed
Hit

Protected Instance Methods

OnChanged

See Also

Breakpoint Class | Debugger Namespace


Breakpoint Properties

The properties of the Breakpoint class are listed below. For a complete list of Breakpoint class members, see the Breakpoint Members topic.

Public Instance Properties

Debugger
Enabled
HadBeenSet
SourcecodeSegment

See Also

Breakpoint Class | Debugger Namespace


Debugger Property

Managed Debugger (by David Srbecky)

Breakpoint.Debugger Property

public NDebugger Debugger {get;}

See Also

Breakpoint Class | Debugger Namespace


Enabled Property

Managed Debugger (by David Srbecky)

Breakpoint.Enabled Property

public Boolean Enabled {get; set;}

See Also

Breakpoint Class | Debugger Namespace


HadBeenSet Property

Managed Debugger (by David Srbecky)

Breakpoint.HadBeenSet Property

public Boolean HadBeenSet {get; set;}

See Also

Breakpoint Class | Debugger Namespace


SourcecodeSegment Property

Managed Debugger (by David Srbecky)

Breakpoint.SourcecodeSegment Property

public SourcecodeSegment SourcecodeSegment {get;}

See Also

Breakpoint Class | Debugger Namespace


Breakpoint Methods

The methods of the Breakpoint class are listed below. For a complete list of Breakpoint class members, see the Breakpoint Members topic.

Public Instance Methods

Equals
GetHashCode
SetBreakpoint

Protected Instance Methods

OnChanged

See Also

Breakpoint Class | Debugger Namespace


Breakpoint.Equals Method

public override bool Equals(
Object obj
);

See Also

Breakpoint Class | Debugger Namespace


Breakpoint.GetHashCode Method

public override int GetHashCode();

See Also

Breakpoint Class | Debugger Namespace


Breakpoint.OnChanged Method

protected void OnChanged();

See Also

Breakpoint Class | Debugger Namespace


Breakpoint.SetBreakpoint Method

public bool SetBreakpoint(
Module module
);

See Also

Breakpoint Class | Debugger Namespace


Breakpoint Events

The events of the Breakpoint class are listed below. For a complete list of Breakpoint class members, see the Breakpoint Members topic.

Public Instance Events

Changed
Hit

See Also

Breakpoint Class | Debugger Namespace


Breakpoint.Changed Event

public event EventHandler<TEventArgs> Changed;

See Also

Breakpoint Class | Debugger Namespace


Breakpoint.Hit Event

public event EventHandler<TEventArgs> Hit;

See Also

Breakpoint Class | Debugger Namespace


BreakpointEventArgs Class

For a list of all members of this type, see BreakpointEventArgs Members.

System.Object
EventArgs
DebuggerEventArgs
BreakpointEventArgs

public class BreakpointEventArgs : DebuggerEventArgs

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

BreakpointEventArgs Members | Debugger Namespace


BreakpointEventArgs Members

BreakpointEventArgs overview

Public Instance Constructors

BreakpointEventArgs Constructor

Public Instance Properties

Breakpoint
Debugger (inherited from DebuggerEventArgs)

See Also

BreakpointEventArgs Class | Debugger Namespace


BreakpointEventArgs Constructor

public BreakpointEventArgs(
Breakpoint breakpoint
);

See Also

BreakpointEventArgs Class | Debugger Namespace


BreakpointEventArgs Properties

The properties of the BreakpointEventArgs class are listed below. For a complete list of BreakpointEventArgs class members, see the BreakpointEventArgs Members topic.

Public Instance Properties

Breakpoint
Debugger (inherited from DebuggerEventArgs)

See Also

BreakpointEventArgs Class | Debugger Namespace


Breakpoint Property

Managed Debugger (by David Srbecky)

BreakpointEventArgs.Breakpoint Property

public Breakpoint Breakpoint {get;}

See Also

BreakpointEventArgs Class | Debugger Namespace


CannotGetValueException Class

For a list of all members of this type, see CannotGetValueException Members.

System.Object
Exception
DebuggerException
CannotGetValueException

public class CannotGetValueException : DebuggerException

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

CannotGetValueException Members | Debugger Namespace


CannotGetValueException Members

CannotGetValueException overview

Public Instance Constructors

CannotGetValueException Constructor

See Also

CannotGetValueException Class | Debugger Namespace


CannotGetValueException Constructor

public CannotGetValueException(
String message
);

See Also

CannotGetValueException Class | Debugger Namespace


DebugeeState Class

Unique identifier of the state of the debugee. Changes when debuggee is stepped, but not when properity is evaluated.

For a list of all members of this type, see DebugeeState Members.

System.Object
DebugeeState

public class DebugeeState : IExpirable, IMutable

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

DebugeeState Members | Debugger Namespace


DebugeeState Members

DebugeeState overview

Public Instance Constructors

DebugeeState Constructor

Public Instance Properties

HasExpired
Process

Public Instance Events

Changed
Expired

See Also

DebugeeState Class | Debugger Namespace


DebugeeState Constructor

public DebugeeState(
Process process
);

See Also

DebugeeState Class | Debugger Namespace


DebugeeState Properties

The properties of the DebugeeState class are listed below. For a complete list of DebugeeState class members, see the DebugeeState Members topic.

Public Instance Properties

HasExpired
Process

See Also

DebugeeState Class | Debugger Namespace


HasExpired Property

Managed Debugger (by David Srbecky)

DebugeeState.HasExpired Property

public Boolean HasExpired {get;}

Implements

IExpirable.HasExpired

See Also

DebugeeState Class | Debugger Namespace


Process Property

Managed Debugger (by David Srbecky)

DebugeeState.Process Property

public Process Process {get;}

See Also

DebugeeState Class | Debugger Namespace


DebugeeState Events

The events of the DebugeeState class are listed below. For a complete list of DebugeeState class members, see the DebugeeState Members topic.

Public Instance Events

Changed
Expired

See Also

DebugeeState Class | Debugger Namespace


DebugeeState.Changed Event

public event EventHandler<TEventArgs> Changed;

Implements

IMutable.Changed

See Also

DebugeeState Class | Debugger Namespace


DebugeeState.Expired Event

public event EventHandler Expired;

Implements

IExpirable.Expired

See Also

DebugeeState Class | Debugger Namespace


DebuggerEventArgs Class

For a list of all members of this type, see DebuggerEventArgs Members.

System.Object
EventArgs
DebuggerEventArgs
BreakpointEventArgs
ProcessEventArgs

public class DebuggerEventArgs : EventArgs

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

DebuggerEventArgs Members | Debugger Namespace


DebuggerEventArgs Members

DebuggerEventArgs overview

Public Instance Constructors

DebuggerEventArgs Constructor

Public Instance Properties

Debugger

See Also

DebuggerEventArgs Class | Debugger Namespace


DebuggerEventArgs Constructor

public DebuggerEventArgs(
NDebugger debugger
);

See Also

DebuggerEventArgs Class | Debugger Namespace


DebuggerEventArgs Properties

The properties of the DebuggerEventArgs class are listed below. For a complete list of DebuggerEventArgs class members, see the DebuggerEventArgs Members topic.

Public Instance Properties

Debugger

See Also

DebuggerEventArgs Class | Debugger Namespace


Debugger Property

Managed Debugger (by David Srbecky)

DebuggerEventArgs.Debugger Property

public NDebugger Debugger {get;}

See Also

DebuggerEventArgs Class | Debugger Namespace


DebuggerException Class

For a list of all members of this type, see DebuggerException Members.

System.Object
Exception
DebuggerException
CannotGetValueException

public class DebuggerException : Exception

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

DebuggerException Members | Debugger Namespace


DebuggerException Members

DebuggerException overview

Public Instance Constructors

DebuggerException Overloaded. Initializes a new instance of the DebuggerException class.

See Also

DebuggerException Class | Debugger Namespace


DebuggerException Constructor

Initializes a new instance of the DebuggerException class.

Overload List

Initializes a new instance of the DebuggerException class.

public DebuggerException();

public DebuggerException(String);

public DebuggerException(String,Exception);

See Also

DebuggerException Class | Debugger Namespace


DebuggerException Constructor ()

Initializes a new instance of the DebuggerException class.

public DebuggerException();

See Also

DebuggerException Class | Debugger Namespace | DebuggerException Constructor Overload List


DebuggerException Constructor (String)

public DebuggerException(
String message
);

See Also

DebuggerException Class | Debugger Namespace | DebuggerException Constructor Overload List


DebuggerException Constructor (String, Exception)

public DebuggerException(
String message,
Exception inner
);

See Also

DebuggerException Class | Debugger Namespace | DebuggerException Constructor Overload List


DebuggerObject Class

A base class for all classes declared by the debugger

For a list of all members of this type, see DebuggerObject Members.

System.Object
MarshalByRefObject
DebuggerObject
Derived types

public class DebuggerObject : MarshalByRefObject

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

DebuggerObject Members | Debugger Namespace


DebuggerObject Members

DebuggerObject overview

Public Instance Constructors

DebuggerObject Constructor Initializes a new instance of the DebuggerObject class.

See Also

DebuggerObject Class | Debugger Namespace


DebuggerObject Constructor

Initializes a new instance of the DebuggerObject class.

public DebuggerObject();

See Also

DebuggerObject Class | Debugger Namespace


DebugType Class

Represents a type in a debugee. That is, a class, array, value type or a primitive type.

This class mimics the Type class.

For a list of all members of this type, see DebugType Members.

System.Object
MarshalByRefObject
DebuggerObject
DebugType

public class DebugType : DebuggerObject

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

DebugType Members | Debugger Namespace


DebugType Members

DebugType overview

Public Instance Properties

BaseType | Gets the type from which this type inherits. Returns null if the current type is Object.
FullName | Returns a string describing the type including the namespace and generic arguments but excluding the assembly name.
HasElementType | Returns true if the type has an element type. (ie array, reference or pointer)
IsArray | Gets a value indicating whether the type is an array
IsClass | Gets a value indicating whether the type is a class
IsGenericType | Gets a value indicating whether the immediate type is generic. Arrays, references and pointers are never generic types.
IsInteger | Gets a value indicating whether the type is an integer type
IsPrimitive | Gets a value indicating whether the type is a primitive type
IsValueType | Gets a value indicating whether the type is a value type (that is, a structre in C#)
ManagedType | Returns simple managed type coresponding to the debug type. Any class yields System.Object
MetadataToken | Gets the metadata token of the class or value type. Only applicable to class or value type!
Module | Gets the module in which the class or value type is defined. Only applicable to class or value type!
Process | Gets the process in which the type was loaded

Public Instance Methods

Equals | Compares two types
GetArrayRank | Returns the number of dimensions of an array
GetElementType | Returns an element type for array, reference or pointer. Retuns null otherwise. (Secificaly, returns null for generic types)
GetFields | Overloaded. Return all public fields.
GetGenericArguments | Returns generics arguments for a type or an emtpy array for non-generic types.
GetHashCode | Get hash code of the object
GetMethods | Overloaded. Return all public methods.
GetProperties | Overloaded. Return all public properties.
IsInstanceOfType | Determines whether the given object is instance of the current type or can be implicitly cast to it
IsSubclassOf | Determines whether the current type is sublass of the the given type. That is, it derives from the given type.

See Also

DebugType Class | Debugger Namespace


DebugType Properties

The properties of the DebugType class are listed below. For a complete list of DebugType class members, see the DebugType Members topic.

Public Instance Properties

BaseType | Gets the type from which this type inherits. Returns null if the current type is Object.
FullName | Returns a string describing the type including the namespace and generic arguments but excluding the assembly name.
HasElementType | Returns true if the type has an element type. (ie array, reference or pointer)
IsArray | Gets a value indicating whether the type is an array
IsClass | Gets a value indicating whether the type is a class
IsGenericType | Gets a value indicating whether the immediate type is generic. Arrays, references and pointers are never generic types.
IsInteger | Gets a value indicating whether the type is an integer type
IsPrimitive | Gets a value indicating whether the type is a primitive type
IsValueType | Gets a value indicating whether the type is a value type (that is, a structre in C#)
ManagedType | Returns simple managed type coresponding to the debug type. Any class yields System.Object
MetadataToken | Gets the metadata token of the class or value type. Only applicable to class or value type!
Module | Gets the module in which the class or value type is defined. Only applicable to class or value type!
Process | Gets the process in which the type was loaded

See Also

DebugType Class | Debugger Namespace


BaseType Property

Managed Debugger (by David Srbecky)

DebugType.BaseType Property

Gets the type from which this type inherits.

Returns null if the current type is Object.

public DebugType BaseType {get;}

See Also

DebugType Class | Debugger Namespace


FullName Property

Managed Debugger (by David Srbecky)

DebugType.FullName Property

Returns a string describing the type including the namespace and generic arguments but excluding the assembly name.

public String FullName {get;}

See Also

DebugType Class | Debugger Namespace


HasElementType Property

Managed Debugger (by David Srbecky)

DebugType.HasElementType Property

Returns true if the type has an element type. (ie array, reference or pointer)

public Boolean HasElementType {get;}

See Also

DebugType Class | Debugger Namespace


IsArray Property

Managed Debugger (by David Srbecky)

DebugType.IsArray Property

Gets a value indicating whether the type is an array

public Boolean IsArray {get;}

See Also

DebugType Class | Debugger Namespace


IsClass Property

Managed Debugger (by David Srbecky)

DebugType.IsClass Property

Gets a value indicating whether the type is a class

public Boolean IsClass {get;}

See Also

DebugType Class | Debugger Namespace


IsGenericType Property

Managed Debugger (by David Srbecky)

DebugType.IsGenericType Property

Gets a value indicating whether the immediate type is generic. Arrays, references and pointers are never generic types.

public Boolean IsGenericType {get;}

See Also

DebugType Class | Debugger Namespace


IsInteger Property

Managed Debugger (by David Srbecky)

DebugType.IsInteger Property

Gets a value indicating whether the type is an integer type

public Boolean IsInteger {get;}

See Also

DebugType Class | Debugger Namespace


IsPrimitive Property

Managed Debugger (by David Srbecky)

DebugType.IsPrimitive Property

Gets a value indicating whether the type is a primitive type

public Boolean IsPrimitive {get;}

See Also

DebugType Class | Debugger Namespace


IsValueType Property

Managed Debugger (by David Srbecky)

DebugType.IsValueType Property

Gets a value indicating whether the type is a value type (that is, a structre in C#)

public Boolean IsValueType {get;}

See Also

DebugType Class | Debugger Namespace


ManagedType Property

Managed Debugger (by David Srbecky)

DebugType.ManagedType Property

Returns simple managed type coresponding to the debug type. Any class yields System.Object

public Type ManagedType {get;}

See Also

DebugType Class | Debugger Namespace


MetadataToken Property

Managed Debugger (by David Srbecky)

DebugType.MetadataToken Property

Gets the metadata token of the class or value type.

Only applicable to class or value type!

public UInt32 MetadataToken {get;}

See Also

DebugType Class | Debugger Namespace


Module Property

Managed Debugger (by David Srbecky)

DebugType.Module Property

Gets the module in which the class or value type is defined.

Only applicable to class or value type!

public Module Module {get;}

See Also

DebugType Class | Debugger Namespace


Process Property

Managed Debugger (by David Srbecky)

DebugType.Process Property

Gets the process in which the type was loaded

public Process Process {get;}

See Also

DebugType Class | Debugger Namespace


DebugType Methods

The methods of the DebugType class are listed below. For a complete list of DebugType class members, see the DebugType Members topic.

Public Instance Methods

Equals | Compares two types
GetArrayRank | Returns the number of dimensions of an array
GetElementType | Returns an element type for array, reference or pointer. Retuns null otherwise. (Secificaly, returns null for generic types)
GetFields | Overloaded. Return all public fields.
GetGenericArguments | Returns generics arguments for a type or an emtpy array for non-generic types.
GetHashCode | Get hash code of the object
GetMethods | Overloaded. Return all public methods.
GetProperties | Overloaded. Return all public properties.
IsInstanceOfType | Determines whether the given object is instance of the current type or can be implicitly cast to it
IsSubclassOf | Determines whether the current type is sublass of the the given type. That is, it derives from the given type.

See Also

DebugType Class | Debugger Namespace


DebugType.Equals Method

Compares two types

public override bool Equals(
Object obj
);

See Also

DebugType Class | Debugger Namespace


DebugType.GetArrayRank Method

Returns the number of dimensions of an array

public int GetArrayRank();

Remarks

Throws ArgumentException if type is not array

See Also

DebugType Class | Debugger Namespace


DebugType.GetElementType Method

Returns an element type for array, reference or pointer. Retuns null otherwise. (Secificaly, returns null for generic types)

public DebugType GetElementType();

See Also

DebugType Class | Debugger Namespace


GetFields Method

Managed Debugger (by David Srbecky)

DebugType.GetFields Method

Return all public fields.

Overload List

Return all public fields.

public IList<T> GetFields();

Return all fields satisfing binding flags.

public IList<T> GetFields(BindingFlags);

See Also

DebugType Class | Debugger Namespace


DebugType.GetFields Method ()

Return all public fields.

public IList<T> GetFields();

See Also

DebugType Class | Debugger Namespace | DebugType.GetFields Overload List


DebugType.GetFields Method (BindingFlags)

Return all fields satisfing binding flags.

public IList<T> GetFields(
BindingFlags bindingFlags
);

See Also

DebugType Class | Debugger Namespace | DebugType.GetFields Overload List


DebugType.GetGenericArguments Method

Returns generics arguments for a type or an emtpy array for non-generic types.

public DebugType[] GetGenericArguments();

See Also

DebugType Class | Debugger Namespace


DebugType.GetHashCode Method

Get hash code of the object

public override int GetHashCode();

See Also

DebugType Class | Debugger Namespace


GetMethods Method

Managed Debugger (by David Srbecky)

DebugType.GetMethods Method

Return all public methods.

Overload List

Return all public methods.

public IList<T> GetMethods();

Return all methods satisfing binding flags.

public IList<T> GetMethods(BindingFlags);

See Also

DebugType Class | Debugger Namespace


DebugType.GetMethods Method ()

Return all public methods.

public IList<T> GetMethods();

See Also

DebugType Class | Debugger Namespace | DebugType.GetMethods Overload List


DebugType.GetMethods Method (BindingFlags)

Return all methods satisfing binding flags.

public IList<T> GetMethods(
BindingFlags bindingFlags
);

See Also

DebugType Class | Debugger Namespace | DebugType.GetMethods Overload List


GetProperties Method

Managed Debugger (by David Srbecky)

DebugType.GetProperties Method

Return all public properties.

Overload List

Return all public properties.

public IList<T> GetProperties();

Return all properties satisfing binding flags.

public IList<T> GetProperties(BindingFlags);

See Also

DebugType Class | Debugger Namespace


DebugType.GetProperties Method ()

Return all public properties.

public IList<T> GetProperties();

See Also

DebugType Class | Debugger Namespace | DebugType.GetProperties Overload List


DebugType.GetProperties Method (BindingFlags)

Return all properties satisfing binding flags.

public IList<T> GetProperties(
BindingFlags bindingFlags
);

See Also

DebugType Class | Debugger Namespace | DebugType.GetProperties Overload List


DebugType.IsInstanceOfType Method

Determines whether the given object is instance of the current type or can be implicitly cast to it

public bool IsInstanceOfType(
Value objectInstance
);

See Also

DebugType Class | Debugger Namespace


DebugType.IsSubclassOf Method

Determines whether the current type is sublass of the the given type. That is, it derives from the given type.

public bool IsSubclassOf(
DebugType superType
);

Remarks

Returns false if the given type is same as the current type

See Also

DebugType Class | Debugger Namespace


Eval Class

This class holds information about function evaluation.

For a list of all members of this type, see Eval Members.

System.Object
MarshalByRefObject
DebuggerObject
Eval

public class Eval : DebuggerObject

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Eval Members | Debugger Namespace


Eval Members

Eval overview

Public Static Methods

AsyncInvokeMethod |
AsyncNewObject |
AsyncNewString |
InvokeMethod | Overloaded. Synchronously calls a function and returns its return value
NewObject |
NewString |

Public Instance Properties

Description
Evaluated
Process
Result
State

Public Instance Methods

EvaluateNow

See Also

Eval Class | Debugger Namespace


Eval Properties

The properties of the Eval class are listed below. For a complete list of Eval class members, see the Eval Members topic.

Public Instance Properties

Description
Evaluated
Process
Result
State

See Also

Eval Class | Debugger Namespace


Description Property

Managed Debugger (by David Srbecky)

Eval.Description Property

public String Description {get;}

See Also

Eval Class | Debugger Namespace


Evaluated Property

Managed Debugger (by David Srbecky)

Eval.Evaluated Property

public Boolean Evaluated {get;}

See Also

Eval Class | Debugger Namespace


Process Property

Managed Debugger (by David Srbecky)

Eval.Process Property

public Process Process {get;}

See Also

Eval Class | Debugger Namespace


Result Property

Managed Debugger (by David Srbecky)

Eval.Result Property

public Value Result {get;}

See Also

Eval Class | Debugger Namespace


State Property

Managed Debugger (by David Srbecky)

Eval.State Property

public EvalState State {get;}

See Also

Eval Class | Debugger Namespace


Eval Methods

The methods of the Eval class are listed below. For a complete list of Eval class members, see the Eval Members topic.

Public Static Methods

AsyncInvokeMethod |
AsyncNewObject |
AsyncNewString |
InvokeMethod | Overloaded. Synchronously calls a function and returns its return value
NewObject |
NewString |

Public Instance Methods

EvaluateNow

See Also

Eval Class | Debugger Namespace


Eval.AsyncInvokeMethod Method

public static Eval AsyncInvokeMethod(
MethodInfo method,
Value thisValue,
Value[] args
);

See Also

Eval Class | Debugger Namespace


Eval.AsyncNewObject Method

public static Eval AsyncNewObject(
Process process,
ICorDebugClass classToCreate
);

See Also

Eval Class | Debugger Namespace


Eval.AsyncNewString Method

public static Eval AsyncNewString(
Process process,
String textToCreate
);

See Also

Eval Class | Debugger Namespace


Eval.EvaluateNow Method

public Value EvaluateNow();

See Also

Eval Class | Debugger Namespace


InvokeMethod Method

Managed Debugger (by David Srbecky)

Eval.InvokeMethod Method

Synchronously calls a function and returns its return value

Overload List

Synchronously calls a function and returns its return value

public static Value InvokeMethod(MethodInfo,Value,Value[]);

Synchronously calls a function and returns its return value

public static Value InvokeMethod(Process,Type,String,Value,Value[]);

See Also

Eval Class | Debugger Namespace


Eval.InvokeMethod Method (MethodInfo, Value, Value[])

Synchronously calls a function and returns its return value

public static Value InvokeMethod(
MethodInfo method,
Value thisValue,
Value[] args
);

See Also

Eval Class | Debugger Namespace | Eval.InvokeMethod Overload List


Eval.InvokeMethod Method (Process, Type, String, Value, Value[])

Synchronously calls a function and returns its return value

public static Value InvokeMethod(
Process process,
Type type,
String name,
Value thisValue,
Value[] args
);

See Also

Eval Class | Debugger Namespace | Eval.InvokeMethod Overload List


Eval.NewObject Method

public static Value NewObject(
Process process,
ICorDebugClass classToCreate
);

See Also

Eval Class | Debugger Namespace


Eval.NewString Method

public static Value NewString(
Process process,
String textToCreate
);

See Also

Eval Class | Debugger Namespace


EvalEventArgs Class

Provides data related to evalution events

For a list of all members of this type, see EvalEventArgs Members.

System.Object
EventArgs
DebuggerEventArgs
ProcessEventArgs
EvalEventArgs

public class EvalEventArgs : ProcessEventArgs

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

EvalEventArgs Members | Debugger Namespace


EvalEventArgs Members

EvalEventArgs overview

Public Instance Constructors

EvalEventArgs Constructor Initializes a new instance of the class

Public Instance Properties

Debugger (inherited from DebuggerEventArgs) |
Eval | The evaluation that caused the event
Process (inherited from ProcessEventArgs) |

See Also

EvalEventArgs Class | Debugger Namespace


EvalEventArgs Constructor

Initializes a new instance of the class

public EvalEventArgs(
Eval eval
);

See Also

EvalEventArgs Class | Debugger Namespace


EvalEventArgs Properties

The properties of the EvalEventArgs class are listed below. For a complete list of EvalEventArgs class members, see the EvalEventArgs Members topic.

Public Instance Properties

Debugger (inherited from DebuggerEventArgs) |
Eval | The evaluation that caused the event
Process (inherited from ProcessEventArgs) |

See Also

EvalEventArgs Class | Debugger Namespace


Eval Property

Managed Debugger (by David Srbecky)

EvalEventArgs.Eval Property

The evaluation that caused the event

public Eval Eval {get;}

See Also

EvalEventArgs Class | Debugger Namespace


EvalState Enumeration

public enum EvalState

Members

Member Name | Description
EvaluationScheduled |
Evaluating |
EvaluatedSuccessfully |
EvaluatedException |
EvaluatedNoResult |
EvaluatedError |

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Debugger Namespace


Exception Class

For a list of all members of this type, see Exception Members.

System.Object
MarshalByRefObject
DebuggerObject
Exception

public class Exception : DebuggerObject

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Exception Members | Debugger Namespace


Exception Members

Exception overview

Public Instance Properties

Callstack
CreationTime
ExceptionType
Location
Message
Process
Type

See Also

Exception Class | Debugger Namespace


Exception Properties

The properties of the Exception class are listed below. For a complete list of Exception class members, see the Exception Members topic.

Public Instance Properties

Callstack
CreationTime
ExceptionType
Location
Message
Process
Type

See Also

Exception Class | Debugger Namespace


Callstack Property

Managed Debugger (by David Srbecky)

Exception.Callstack Property

public String Callstack {get;}

See Also

Exception Class | Debugger Namespace


CreationTime Property

Managed Debugger (by David Srbecky)

Exception.CreationTime Property

public DateTime CreationTime {get;}

See Also

Exception Class | Debugger Namespace


ExceptionType Property

Managed Debugger (by David Srbecky)

Exception.ExceptionType Property

public ExceptionType ExceptionType {get;}

See Also

Exception Class | Debugger Namespace


Location Property

Managed Debugger (by David Srbecky)

Exception.Location Property

public SourcecodeSegment Location {get;}

See Also

Exception Class | Debugger Namespace


Message Property

Managed Debugger (by David Srbecky)

Exception.Message Property

public String Message {get;}

See Also

Exception Class | Debugger Namespace


Process Property

Managed Debugger (by David Srbecky)

Exception.Process Property

public Process Process {get;}

See Also

Exception Class | Debugger Namespace


Type Property

Managed Debugger (by David Srbecky)

Exception.Type Property

public String Type {get;}

See Also

Exception Class | Debugger Namespace


ExceptionEventArgs Class

For a list of all members of this type, see ExceptionEventArgs Members.

System.Object
EventArgs
DebuggerEventArgs
ProcessEventArgs
ExceptionEventArgs

public class ExceptionEventArgs : ProcessEventArgs

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

ExceptionEventArgs Members | Debugger Namespace


ExceptionEventArgs Members

ExceptionEventArgs overview

Public Instance Constructors

ExceptionEventArgs Constructor

Public Instance Properties

Continue
Debugger (inherited from DebuggerEventArgs)
Exception
Process (inherited from ProcessEventArgs)

See Also

ExceptionEventArgs Class | Debugger Namespace


ExceptionEventArgs Constructor

public ExceptionEventArgs(
Process process,
Exception exception
);

See Also

ExceptionEventArgs Class | Debugger Namespace


ExceptionEventArgs Properties

The properties of the ExceptionEventArgs class are listed below. For a complete list of ExceptionEventArgs class members, see the ExceptionEventArgs Members topic.

Public Instance Properties

Continue
Debugger (inherited from DebuggerEventArgs)
Exception
Process (inherited from ProcessEventArgs)

See Also

ExceptionEventArgs Class | Debugger Namespace


Continue Property

Managed Debugger (by David Srbecky)

ExceptionEventArgs.Continue Property

public Boolean Continue {get; set;}

See Also

ExceptionEventArgs Class | Debugger Namespace


Exception Property

Managed Debugger (by David Srbecky)

ExceptionEventArgs.Exception Property

public Exception Exception {get;}

See Also

ExceptionEventArgs Class | Debugger Namespace


ExceptionType Enumeration

public enum ExceptionType

Members

Member Name | Description
DEBUG_EXCEPTION_FIRST_CHANCE |
DEBUG_EXCEPTION_UNHANDLED |
DEBUG_EXCEPTION_USER_FIRST_CHANCE |
DEBUG_EXCEPTION_CATCH_HANDLER_FOUND |

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Debugger Namespace


FieldInfo Class

Provides information about a field of some class.

For a list of all members of this type, see FieldInfo Members.

System.Object
MarshalByRefObject
DebuggerObject
MemberInfo
FieldInfo

public class FieldInfo : MemberInfo

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

FieldInfo Members | Debugger Namespace


FieldInfo Members

FieldInfo overview

Public Instance Properties

DeclaringType (inherited from MemberInfo) | Gets the type that declares this member element
IsLiteral | Gets a value indicating whether this field is literal field
IsPrivate | Gets a value indicating whether this field is private
IsPublic | Gets a value indicating whether this field is public
IsStatic | Gets a value indicating whether this field is static
MetadataToken | Gets the metadata token associated with this field
Module (inherited from MemberInfo) | Gets the module in which this member is defined
Name | Gets the name of this field
Process (inherited from MemberInfo) | Gets the process in which the type was loaded

Public Instance Methods

GetValue Given an object of correct type, get the value of this field

See Also

FieldInfo Class | Debugger Namespace


FieldInfo Properties

The properties of the FieldInfo class are listed below. For a complete list of FieldInfo class members, see the FieldInfo Members topic.

Public Instance Properties

DeclaringType (inherited from MemberInfo) | Gets the type that declares this member element
IsLiteral | Gets a value indicating whether this field is literal field
IsPrivate | Gets a value indicating whether this field is private
IsPublic | Gets a value indicating whether this field is public
IsStatic | Gets a value indicating whether this field is static
MetadataToken | Gets the metadata token associated with this field
Module (inherited from MemberInfo) | Gets the module in which this member is defined
Name | Gets the name of this field
Process (inherited from MemberInfo) | Gets the process in which the type was loaded

See Also

FieldInfo Class | Debugger Namespace


IsLiteral Property

Managed Debugger (by David Srbecky)

FieldInfo.IsLiteral Property

Gets a value indicating whether this field is literal field

public Boolean IsLiteral {get;}

See Also

FieldInfo Class | Debugger Namespace


IsPrivate Property

Managed Debugger (by David Srbecky)

FieldInfo.IsPrivate Property

Gets a value indicating whether this field is private

public override Boolean IsPrivate {get;}

See Also

FieldInfo Class | Debugger Namespace


IsPublic Property

Managed Debugger (by David Srbecky)

FieldInfo.IsPublic Property

Gets a value indicating whether this field is public

public override Boolean IsPublic {get;}

See Also

FieldInfo Class | Debugger Namespace


IsStatic Property

Managed Debugger (by David Srbecky)

FieldInfo.IsStatic Property

Gets a value indicating whether this field is static

public override Boolean IsStatic {get;}

See Also

FieldInfo Class | Debugger Namespace


MetadataToken Property

Managed Debugger (by David Srbecky)

FieldInfo.MetadataToken Property

Gets the metadata token associated with this field

public override UInt32 MetadataToken {get;}

See Also

FieldInfo Class | Debugger Namespace


Name Property

Managed Debugger (by David Srbecky)

FieldInfo.Name Property

Gets the name of this field

public override String Name {get;}

See Also

FieldInfo Class | Debugger Namespace


FieldInfo Methods

The methods of the FieldInfo class are listed below. For a complete list of FieldInfo class members, see the FieldInfo Members topic.

Public Instance Methods

GetValue Given an object of correct type, get the value of this field

See Also

FieldInfo Class | Debugger Namespace


FieldInfo.GetValue Method

Given an object of correct type, get the value of this field

public MemberValue GetValue(
Value objectInstance
);

See Also

FieldInfo Class | Debugger Namespace


Function Class

A function (or also a method or frame) which is being executed on some thread. Use to obtain arguments or local variables.

For a list of all members of this type, see Function Members.

System.Object
MarshalByRefObject
DebuggerObject
Function

public class Function : DebuggerObject, IExpirable

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Function Members | Debugger Namespace


Function Members

Function overview

Public Instance Properties

ArgumentCount | Total number of arguments (excluding implicit 'this' argument)
Arguments | Gets all arguments of the function.
ContaingClassVariables | Gets all accessible members of the class that defines this function.
HasExpired | True if function stepped out and is not longer valid.
HasSymbols | True if the function has symbols defined. (That is has accesss to the .pdb file)
IsStatic | True if the function is static
LocalVariables | Gets all local variables of the function.
Module | A module in which the function is defined
Name | The name of the function (eg "ToString")
NextStatement | Get the information about the next statement to be executed. Returns null on error.
Process | The process in which this function is executed
ThisValue | Gets the instance of the class asociated with the current frame. That is, 'this' in C#.
Thread | A thread in which the function is executed
Token | Metadata token of the function
Variables | Gets all variables in the lexical scope of the function. That is, arguments, local variables and varables of the containing class.

Public Instance Methods

CanSetIP | Determine whether the instrustion pointer can be set to given location
GetArgument | Gets argument with a given index
GetParameterName | Gets the name of given parameter
SetIP | Set the instrustion pointer to given location
StepInto | Step into next instruction
StepOut | Step out of the function
StepOver | Step over next instruction
ToString | Returns diagnostic description of the frame

Public Instance Events

Expired Occurs when function expires and is no longer usable

Protected Internal Instance Methods

OnExpired Is called when function expires and is no longer usable

See Also

Function Class | Debugger Namespace


Function Properties

The properties of the Function class are listed below. For a complete list of Function class members, see the Function Members topic.

Public Instance Properties

ArgumentCount | Total number of arguments (excluding implicit 'this' argument)
Arguments | Gets all arguments of the function.
ContaingClassVariables | Gets all accessible members of the class that defines this function.
HasExpired | True if function stepped out and is not longer valid.
HasSymbols | True if the function has symbols defined. (That is has accesss to the .pdb file)
IsStatic | True if the function is static
LocalVariables | Gets all local variables of the function.
Module | A module in which the function is defined
Name | The name of the function (eg "ToString")
NextStatement | Get the information about the next statement to be executed. Returns null on error.
Process | The process in which this function is executed
ThisValue | Gets the instance of the class asociated with the current frame. That is, 'this' in C#.
Thread | A thread in which the function is executed
Token | Metadata token of the function
Variables | Gets all variables in the lexical scope of the function. That is, arguments, local variables and varables of the containing class.

See Also

Function Class | Debugger Namespace


ArgumentCount Property

Managed Debugger (by David Srbecky)

Function.ArgumentCount Property

Total number of arguments (excluding implicit 'this' argument)

public Int32 ArgumentCount {get;}

See Also

Function Class | Debugger Namespace


Arguments Property

Managed Debugger (by David Srbecky)

Function.Arguments Property

Gets all arguments of the function.

public NamedValueCollection Arguments {get;}

See Also

Function Class | Debugger Namespace


ContaingClassVariables Property

Managed Debugger (by David Srbecky)

Function.ContaingClassVariables Property

Gets all accessible members of the class that defines this function.

public NamedValueCollection ContaingClassVariables {get;}

See Also

Function Class | Debugger Namespace


HasExpired Property

Managed Debugger (by David Srbecky)

Function.HasExpired Property

True if function stepped out and is not longer valid.

public Boolean HasExpired {get;}

Implements

IExpirable.HasExpired

See Also

Function Class | Debugger Namespace


HasSymbols Property

Managed Debugger (by David Srbecky)

Function.HasSymbols Property

True if the function has symbols defined. (That is has accesss to the .pdb file)

public Boolean HasSymbols {get;}

See Also

Function Class | Debugger Namespace


IsStatic Property

Managed Debugger (by David Srbecky)

Function.IsStatic Property

True if the function is static

public Boolean IsStatic {get;}

See Also

Function Class | Debugger Namespace


LocalVariables Property

Managed Debugger (by David Srbecky)

Function.LocalVariables Property

Gets all local variables of the function.

public NamedValueCollection LocalVariables {get;}

See Also

Function Class | Debugger Namespace


Module Property

Managed Debugger (by David Srbecky)

Function.Module Property

A module in which the function is defined

public Module Module {get;}

See Also

Function Class | Debugger Namespace


Name Property

Managed Debugger (by David Srbecky)

Function.Name Property

The name of the function (eg "ToString")

public String Name {get;}

See Also

Function Class | Debugger Namespace


NextStatement Property

Managed Debugger (by David Srbecky)

Function.NextStatement Property

Get the information about the next statement to be executed. Returns null on error.

public SourcecodeSegment NextStatement {get;}

See Also

Function Class | Debugger Namespace


Process Property

Managed Debugger (by David Srbecky)

Function.Process Property

The process in which this function is executed

public Process Process {get;}

See Also

Function Class | Debugger Namespace


ThisValue Property

Managed Debugger (by David Srbecky)

Function.ThisValue Property

Gets the instance of the class asociated with the current frame. That is, 'this' in C#.

public NamedValue ThisValue {get;}

See Also

Function Class | Debugger Namespace


Thread Property

Managed Debugger (by David Srbecky)

Function.Thread Property

A thread in which the function is executed

public Thread Thread {get;}

See Also

Function Class | Debugger Namespace


Token Property

Managed Debugger (by David Srbecky)

Function.Token Property

Metadata token of the function

public UInt32 Token {get;}

See Also

Function Class | Debugger Namespace


Variables Property

Managed Debugger (by David Srbecky)

Function.Variables Property

Gets all variables in the lexical scope of the function. That is, arguments, local variables and varables of the containing class.

public NamedValueCollection Variables {get;}

See Also

Function Class | Debugger Namespace


Function Methods

The methods of the Function class are listed below. For a complete list of Function class members, see the Function Members topic.

Public Instance Methods

CanSetIP | Determine whether the instrustion pointer can be set to given location
GetArgument | Gets argument with a given index
GetParameterName | Gets the name of given parameter
SetIP | Set the instrustion pointer to given location
StepInto | Step into next instruction
StepOut | Step out of the function
StepOver | Step over next instruction
ToString | Returns diagnostic description of the frame

Protected Internal Instance Methods

OnExpired Is called when function expires and is no longer usable

See Also

Function Class | Debugger Namespace


Function.CanSetIP Method

Determine whether the instrustion pointer can be set to given location

public SourcecodeSegment CanSetIP(
String filename,
Int32 line,
Int32 column
);

Return Value

Best possible location. Null is not possible.

See Also

Function Class | Debugger Namespace


Function.GetArgument Method

Gets argument with a given index

public MethodArgument GetArgument(
Int32 index
);

Parameters

index
Zero-based index

See Also

Function Class | Debugger Namespace


Function.GetParameterName Method

Gets the name of given parameter

public string GetParameterName(
Int32 index
);

Parameters

index
Zero-based index

See Also

Function Class | Debugger Namespace


Function.OnExpired Method

Is called when function expires and is no longer usable

protected internal virtual void OnExpired(
EventArgs e
);

See Also

Function Class | Debugger Namespace


Function.SetIP Method

Set the instrustion pointer to given location

public SourcecodeSegment SetIP(
String filename,
Int32 line,
Int32 column
);

Return Value

Best possible location. Null is not possible.

See Also

Function Class | Debugger Namespace


Function.StepInto Method

Step into next instruction

public void StepInto();

See Also

Function Class | Debugger Namespace


Function.StepOut Method

Step out of the function

public void StepOut();

See Also

Function Class | Debugger Namespace


Function.StepOver Method

Step over next instruction

public void StepOver();

See Also

Function Class | Debugger Namespace


Function.ToString Method

Returns diagnostic description of the frame

public override string ToString();

See Also

Function Class | Debugger Namespace


Function Events

The events of the Function class are listed below. For a complete list of Function class members, see the Function Members topic.

Public Instance Events

Expired Occurs when function expires and is no longer usable

See Also

Function Class | Debugger Namespace


Function.Expired Event

Occurs when function expires and is no longer usable

public event EventHandler Expired;

Implements

IExpirable.Expired

See Also

Function Class | Debugger Namespace


IExpirable Interface

For a list of all members of this type, see IExpirable Members.

public interface IExpirable

Types that implement IExpirable

Type | Description
ArrayElement | Represents an element of an array
DebugeeState | Unique identifier of the state of the debugee. Changes when debuggee is stepped, but not when properity is evaluated.
Function | A function (or also a method or frame) which is being executed on some thread. Use to obtain arguments or local variables.
LocalVariable | Represents a local variable in a function
MemberValue | Represents a member of class or value type - that is, a field or a property
MethodArgument | Represents an argument of a function. That is, it refers to the runtime value of function parameter.
NamedValue | NamedValue is a Value which has some name associated with it - eg the name of the field that holds the value.
PauseSession | Holds information about the state of paused debugger. Expires when when Continue is called on debugger.
Process |
Thread |
Value | Provides more specific access

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

IExpirable Members | Debugger Namespace


IExpirable Members

IExpirable overview

Public Instance Properties

HasExpired

Public Instance Events

Expired

See Also

IExpirable Interface | Debugger Namespace


IExpirable Properties

The properties of the IExpirable interface are listed below. For a complete list of IExpirable interface members, see the IExpirable Members topic.

Public Instance Properties

HasExpired

See Also

IExpirable Interface | Debugger Namespace


HasExpired Property

Managed Debugger (by David Srbecky)

IExpirable.HasExpired Property

Boolean HasExpired {get;}

See Also

IExpirable Interface | Debugger Namespace


IExpirable Events

The events of the IExpirable interface are listed below. For a complete list of IExpirable interface members, see the IExpirable Members topic.

Public Instance Events

Expired

See Also

IExpirable Interface | Debugger Namespace


IExpirable.Expired Event

event EventHandler Expired;

See Also

IExpirable Interface | Debugger Namespace


IMutable Interface

For a list of all members of this type, see IMutable Members.

public interface IMutable

Types that implement IMutable

Type | Description
ArrayElement | Represents an element of an array
DebugeeState | Unique identifier of the state of the debugee. Changes when debuggee is stepped, but not when properity is evaluated.
LocalVariable | Represents a local variable in a function
MemberValue | Represents a member of class or value type - that is, a field or a property
MethodArgument | Represents an argument of a function. That is, it refers to the runtime value of function parameter.
NamedValue | NamedValue is a Value which has some name associated with it - eg the name of the field that holds the value.
Value | Provides more specific access

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

IMutable Members | Debugger Namespace


IMutable Members

IMutable overview

Public Instance Events

Changed

See Also

IMutable Interface | Debugger Namespace


IMutable Events

The events of the IMutable interface are listed below. For a complete list of IMutable interface members, see the IMutable Members topic.

Public Instance Events

Changed

See Also

IMutable Interface | Debugger Namespace


IMutable.Changed Event

event EventHandler<TEventArgs> Changed;

See Also

IMutable Interface | Debugger Namespace


LocalVariable Class

Represents a local variable in a function

For a list of all members of this type, see LocalVariable Members.

System.Object
MarshalByRefObject
DebuggerObject
Value
NamedValue
LocalVariable

public class LocalVariable : NamedValue

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

LocalVariable Members | Debugger Namespace


LocalVariable Members

LocalVariable overview

Public Instance Properties

ArrayDimensions (inherited from Value) | Gets the lengths of individual dimensions. eg new object[4,5] returns {4,5};
ArrayLenght (inherited from Value) | Gets the number of elements the array can store. eg new object[4,5] returns 20
ArrayRank (inherited from Value) | Gets the number of dimensions of the array. eg new object[4,5] returns 2
AsString (inherited from Value) | Gets a string representation of the value
HasExpired (inherited from Value) | Returns true if the Value have expired and can not be used anymore
IsArray (inherited from Value) | Returns true if the value is an array
IsInteger (inherited from Value) | Gets a value indicating whether the type is an integer type
IsNull (inherited from Value) | Returns true if the value is null
IsObject (inherited from Value) | Returns true if the value is a class or value type
IsPrimitive (inherited from Value) | Returns true if the value is an primitive type. eg int, bool, string
Name (inherited from NamedValue) | Gets the name associated with the value
PrimitiveValue (inherited from Value) | Gets or sets the value of a primitive type. If setting of a value fails, NotSupportedException is thrown.
Process (inherited from Value) | The process that owns the value
Type (inherited from Value) | Returns the DebugType of the value

Public Instance Methods

GetArrayElement (inherited from Value) | Overloaded. Returns an element of a single-dimensional array
GetArrayElements (inherited from Value) | Returns all elements in the array
GetMember (inherited from Value) | Get a field or property of an object with a given name.
GetMembers (inherited from Value) | Overloaded. Get all fields and properties of an object.
SetValue (inherited from Value) | Copy the acutal value from some other Value object

Public Instance Events

Changed (inherited from Value) | Occurs when the Value have potentialy changed
Expired (inherited from Value) | Occurs when the Value can not be used anymore

Protected Instance Methods

OnChanged (inherited from Value) | Is called when the value changes
OnExpired (inherited from Value) | Is called when the value expires and can not be used anymore

See Also

LocalVariable Class | Debugger Namespace


MemberInfo Class

Provides information about a member of some class (eg. a field or a method).

For a list of all members of this type, see MemberInfo Members.

System.Object
MarshalByRefObject
DebuggerObject
MemberInfo
FieldInfo
MethodInfo
PropertyInfo

public class MemberInfo : DebuggerObject

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

MemberInfo Members | Debugger Namespace


MemberInfo Members

MemberInfo overview

Public Instance Properties

DeclaringType | Gets the type that declares this member element
IsPrivate | Gets a value indicating whether this member is private
IsPublic | Gets a value indicating whether this member is public
IsStatic | Gets a value indicating whether this member is static
MetadataToken | Gets the metadata token associated with this member
Module | Gets the module in which this member is defined
Name | Gets the name of this member
Process | Gets the process in which the type was loaded

See Also

MemberInfo Class | Debugger Namespace


MemberInfo Properties

The properties of the MemberInfo class are listed below. For a complete list of MemberInfo class members, see the MemberInfo Members topic.

Public Instance Properties

DeclaringType | Gets the type that declares this member element
IsPrivate | Gets a value indicating whether this member is private
IsPublic | Gets a value indicating whether this member is public
IsStatic | Gets a value indicating whether this member is static
MetadataToken | Gets the metadata token associated with this member
Module | Gets the module in which this member is defined
Name | Gets the name of this member
Process | Gets the process in which the type was loaded

See Also

MemberInfo Class | Debugger Namespace


DeclaringType Property

Managed Debugger (by David Srbecky)

MemberInfo.DeclaringType Property

Gets the type that declares this member element

public DebugType DeclaringType {get;}

See Also

MemberInfo Class | Debugger Namespace


IsPrivate Property

Managed Debugger (by David Srbecky)

MemberInfo.IsPrivate Property

Gets a value indicating whether this member is private

public abstract Boolean IsPrivate {get;}

See Also

MemberInfo Class | Debugger Namespace


IsPublic Property

Managed Debugger (by David Srbecky)

MemberInfo.IsPublic Property

Gets a value indicating whether this member is public

public abstract Boolean IsPublic {get;}

See Also

MemberInfo Class | Debugger Namespace


IsStatic Property

Managed Debugger (by David Srbecky)

MemberInfo.IsStatic Property

Gets a value indicating whether this member is static

public abstract Boolean IsStatic {get;}

See Also

MemberInfo Class | Debugger Namespace


MetadataToken Property

Managed Debugger (by David Srbecky)

MemberInfo.MetadataToken Property

Gets the metadata token associated with this member

public abstract UInt32 MetadataToken {get;}

See Also

MemberInfo Class | Debugger Namespace


Module Property

Managed Debugger (by David Srbecky)

MemberInfo.Module Property

Gets the module in which this member is defined

public Module Module {get;}

See Also

MemberInfo Class | Debugger Namespace


Name Property

Managed Debugger (by David Srbecky)

MemberInfo.Name Property

Gets the name of this member

public abstract String Name {get;}

See Also

MemberInfo Class | Debugger Namespace


Process Property

Managed Debugger (by David Srbecky)

MemberInfo.Process Property

Gets the process in which the type was loaded

public Process Process {get;}

See Also

MemberInfo Class | Debugger Namespace


MemberValue Class

Represents a member of class or value type - that is, a field or a property

For a list of all members of this type, see MemberValue Members.

System.Object
MarshalByRefObject
DebuggerObject
Value
NamedValue
MemberValue

public class MemberValue : NamedValue

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

MemberValue Members | Debugger Namespace


MemberValue Members

MemberValue overview

Public Instance Properties

ArrayDimensions (inherited from Value) | Gets the lengths of individual dimensions. eg new object[4,5] returns {4,5};
ArrayLenght (inherited from Value) | Gets the number of elements the array can store. eg new object[4,5] returns 20
ArrayRank (inherited from Value) | Gets the number of dimensions of the array. eg new object[4,5] returns 2
AsString (inherited from Value) | Gets a string representation of the value
HasExpired (inherited from Value) | Returns true if the Value have expired and can not be used anymore
IsArray (inherited from Value) | Returns true if the value is an array
IsInteger (inherited from Value) | Gets a value indicating whether the type is an integer type
IsNull (inherited from Value) | Returns true if the value is null
IsObject (inherited from Value) | Returns true if the value is a class or value type
IsPrimitive (inherited from Value) | Returns true if the value is an primitive type. eg int, bool, string
MemberInfo | Gets an MemberInfo object which can be used to obtain metadata information about the member.
Name (inherited from NamedValue) | Gets the name associated with the value
PrimitiveValue (inherited from Value) | Gets or sets the value of a primitive type. If setting of a value fails, NotSupportedException is thrown.
Process (inherited from Value) | The process that owns the value
Type (inherited from Value) | Returns the DebugType of the value

Public Instance Methods

GetArrayElement (inherited from Value) | Overloaded. Returns an element of a single-dimensional array
GetArrayElements (inherited from Value) | Returns all elements in the array
GetMember (inherited from Value) | Get a field or property of an object with a given name.
GetMembers (inherited from Value) | Overloaded. Get all fields and properties of an object.
SetValue (inherited from Value) | Copy the acutal value from some other Value object

Public Instance Events

Changed (inherited from Value) | Occurs when the Value have potentialy changed
Expired (inherited from Value) | Occurs when the Value can not be used anymore

Protected Instance Methods

OnChanged (inherited from Value) | Is called when the value changes
OnExpired (inherited from Value) | Is called when the value expires and can not be used anymore

See Also

MemberValue Class | Debugger Namespace


MemberValue Properties

The properties of the MemberValue class are listed below. For a complete list of MemberValue class members, see the MemberValue Members topic.

Public Instance Properties

ArrayDimensions (inherited from Value) | Gets the lengths of individual dimensions. eg new object[4,5] returns {4,5};
ArrayLenght (inherited from Value) | Gets the number of elements the array can store. eg new object[4,5] returns 20
ArrayRank (inherited from Value) | Gets the number of dimensions of the array. eg new object[4,5] returns 2
AsString (inherited from Value) | Gets a string representation of the value
HasExpired (inherited from Value) | Returns true if the Value have expired and can not be used anymore
IsArray (inherited from Value) | Returns true if the value is an array
IsInteger (inherited from Value) | Gets a value indicating whether the type is an integer type
IsNull (inherited from Value) | Returns true if the value is null
IsObject (inherited from Value) | Returns true if the value is a class or value type
IsPrimitive (inherited from Value) | Returns true if the value is an primitive type. eg int, bool, string
MemberInfo | Gets an MemberInfo object which can be used to obtain metadata information about the member.
Name (inherited from NamedValue) | Gets the name associated with the value
PrimitiveValue (inherited from Value) | Gets or sets the value of a primitive type. If setting of a value fails, NotSupportedException is thrown.
Process (inherited from Value) | The process that owns the value
Type (inherited from Value) | Returns the DebugType of the value

See Also

MemberValue Class | Debugger Namespace


MemberInfo Property

Managed Debugger (by David Srbecky)

MemberValue.MemberInfo Property

Gets an MemberInfo object which can be used to obtain metadata information about the member.

public MemberInfo MemberInfo {get;}

See Also

MemberValue Class | Debugger Namespace


MessageEventArgs Class

For a list of all members of this type, see MessageEventArgs Members.

System.Object
EventArgs
DebuggerEventArgs
ProcessEventArgs
MessageEventArgs

public class MessageEventArgs : ProcessEventArgs

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

MessageEventArgs Members | Debugger Namespace


MessageEventArgs Members

MessageEventArgs overview

Public Instance Constructors

MessageEventArgs Overloaded. Initializes a new instance of the MessageEventArgs class.

Public Instance Properties

Category
Debugger (inherited from DebuggerEventArgs)
Level
Message
Process (inherited from ProcessEventArgs)

See Also

MessageEventArgs Class | Debugger Namespace


MessageEventArgs Constructor

Overload List

public MessageEventArgs(Process,Int32,String,String);

public MessageEventArgs(Process,String);

See Also

MessageEventArgs Class | Debugger Namespace


MessageEventArgs Constructor (Process, String)

public MessageEventArgs(
Process process,
String message
);

See Also

MessageEventArgs Class | Debugger Namespace | MessageEventArgs Constructor Overload List


MessageEventArgs Constructor (Process, Int32, String, String)

public MessageEventArgs(
Process process,
Int32 level,
String message,
String category
);

See Also

MessageEventArgs Class | Debugger Namespace | MessageEventArgs Constructor Overload List


MessageEventArgs Properties

The properties of the MessageEventArgs class are listed below. For a complete list of MessageEventArgs class members, see the MessageEventArgs Members topic.

Public Instance Properties

Category
Debugger (inherited from DebuggerEventArgs)
Level
Message
Process (inherited from ProcessEventArgs)

See Also

MessageEventArgs Class | Debugger Namespace


Category Property

Managed Debugger (by David Srbecky)

MessageEventArgs.Category Property

public String Category {get;}

See Also

MessageEventArgs Class | Debugger Namespace


Level Property

Managed Debugger (by David Srbecky)

MessageEventArgs.Level Property

public Int32 Level {get;}

See Also

MessageEventArgs Class | Debugger Namespace


Message Property

Managed Debugger (by David Srbecky)

MessageEventArgs.Message Property

public String Message {get;}

See Also

MessageEventArgs Class | Debugger Namespace


MethodArgument Class

Represents an argument of a function. That is, it refers to the runtime value of function parameter.

For a list of all members of this type, see MethodArgument Members.

System.Object
MarshalByRefObject
DebuggerObject
Value
NamedValue
MethodArgument

public class MethodArgument : NamedValue

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

MethodArgument Members | Debugger Namespace


MethodArgument Members

MethodArgument overview

Public Instance Properties

ArrayDimensions (inherited from Value) | Gets the lengths of individual dimensions. eg new object[4,5] returns {4,5};
ArrayLenght (inherited from Value) | Gets the number of elements the array can store. eg new object[4,5] returns 20
ArrayRank (inherited from Value) | Gets the number of dimensions of the array. eg new object[4,5] returns 2
AsString (inherited from Value) | Gets a string representation of the value
HasExpired (inherited from Value) | Returns true if the Value have expired and can not be used anymore
Index | The index of the function parameter starting at 0.
IsArray (inherited from Value) | Returns true if the value is an array
IsInteger (inherited from Value) | Gets a value indicating whether the type is an integer type
IsNull (inherited from Value) | Returns true if the value is null
IsObject (inherited from Value) | Returns true if the value is a class or value type
IsPrimitive (inherited from Value) | Returns true if the value is an primitive type. eg int, bool, string
Name (inherited from NamedValue) | Gets the name associated with the value
PrimitiveValue (inherited from Value) | Gets or sets the value of a primitive type. If setting of a value fails, NotSupportedException is thrown.
Process (inherited from Value) | The process that owns the value
Type (inherited from Value) | Returns the DebugType of the value

Public Instance Methods

GetArrayElement (inherited from Value) | Overloaded. Returns an element of a single-dimensional array
GetArrayElements (inherited from Value) | Returns all elements in the array
GetMember (inherited from Value) | Get a field or property of an object with a given name.
GetMembers (inherited from Value) | Overloaded. Get all fields and properties of an object.
SetValue (inherited from Value) | Copy the acutal value from some other Value object

Public Instance Events

Changed (inherited from Value) | Occurs when the Value have potentialy changed
Expired (inherited from Value) | Occurs when the Value can not be used anymore

Protected Instance Methods

OnChanged (inherited from Value) | Is called when the value changes
OnExpired (inherited from Value) | Is called when the value expires and can not be used anymore

See Also

MethodArgument Class | Debugger Namespace


MethodArgument Properties

The properties of the MethodArgument class are listed below. For a complete list of MethodArgument class members, see the MethodArgument Members topic.

Public Instance Properties

ArrayDimensions (inherited from Value) | Gets the lengths of individual dimensions. eg new object[4,5] returns {4,5};
ArrayLenght (inherited from Value) | Gets the number of elements the array can store. eg new object[4,5] returns 20
ArrayRank (inherited from Value) | Gets the number of dimensions of the array. eg new object[4,5] returns 2
AsString (inherited from Value) | Gets a string representation of the value
HasExpired (inherited from Value) | Returns true if the Value have expired and can not be used anymore
Index | The index of the function parameter starting at 0.
IsArray (inherited from Value) | Returns true if the value is an array
IsInteger (inherited from Value) | Gets a value indicating whether the type is an integer type
IsNull (inherited from Value) | Returns true if the value is null
IsObject (inherited from Value) | Returns true if the value is a class or value type
IsPrimitive (inherited from Value) | Returns true if the value is an primitive type. eg int, bool, string
Name (inherited from NamedValue) | Gets the name associated with the value
PrimitiveValue (inherited from Value) | Gets or sets the value of a primitive type. If setting of a value fails, NotSupportedException is thrown.
Process (inherited from Value) | The process that owns the value
Type (inherited from Value) | Returns the DebugType of the value

See Also

MethodArgument Class | Debugger Namespace


Index Property

Managed Debugger (by David Srbecky)

MethodArgument.Index Property

The index of the function parameter starting at 0.

public Int32 Index {get;}

Remarks

The implicit 'this' is excluded.

See Also

MethodArgument Class | Debugger Namespace


MethodInfo Class

Provides information about a method in a class

For a list of all members of this type, see MethodInfo Members.

System.Object
MarshalByRefObject
DebuggerObject
MemberInfo
MethodInfo

public class MethodInfo : MemberInfo

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

MethodInfo Members | Debugger Namespace


MethodInfo Members

MethodInfo overview

Public Static Methods

GetFromName Get a method from a managed type, method name and argument count

Public Instance Properties

DeclaringType (inherited from MemberInfo) | Gets the type that declares this member element
IsPrivate | Gets a value indicating whether this method is private
IsPublic | Gets a value indicating whether this method is public
IsSpecialName | Gets a value indicating whether the name of this method is marked as specail.
IsStatic | Gets a value indicating whether this method is static
MetadataToken | Gets the metadata token associated with this method
Module (inherited from MemberInfo) | Gets the module in which this member is defined
Name | Gets the name of this method
Process (inherited from MemberInfo) | Gets the process in which the type was loaded

Public Instance Methods

AsyncInvoke | Asynchronously invoke the method of an a given object
Invoke | Synchronously invoke the method of an a given object

See Also

MethodInfo Class | Debugger Namespace


MethodInfo Properties

The properties of the MethodInfo class are listed below. For a complete list of MethodInfo class members, see the MethodInfo Members topic.

Public Instance Properties

DeclaringType (inherited from MemberInfo) | Gets the type that declares this member element
IsPrivate | Gets a value indicating whether this method is private
IsPublic | Gets a value indicating whether this method is public
IsSpecialName | Gets a value indicating whether the name of this method is marked as specail.
IsStatic | Gets a value indicating whether this method is static
MetadataToken | Gets the metadata token associated with this method
Module (inherited from MemberInfo) | Gets the module in which this member is defined
Name | Gets the name of this method
Process (inherited from MemberInfo) | Gets the process in which the type was loaded

See Also

MethodInfo Class | Debugger Namespace


IsPrivate Property

Managed Debugger (by David Srbecky)

MethodInfo.IsPrivate Property

Gets a value indicating whether this method is private

public override Boolean IsPrivate {get;}

See Also

MethodInfo Class | Debugger Namespace


IsPublic Property

Managed Debugger (by David Srbecky)

MethodInfo.IsPublic Property

Gets a value indicating whether this method is public

public override Boolean IsPublic {get;}

See Also

MethodInfo Class | Debugger Namespace


IsSpecialName Property

Managed Debugger (by David Srbecky)

MethodInfo.IsSpecialName Property

Gets a value indicating whether the name of this method is marked as specail.

public Boolean IsSpecialName {get;}

Remarks

For example, property accessors are marked as special

See Also

MethodInfo Class | Debugger Namespace


IsStatic Property

Managed Debugger (by David Srbecky)

MethodInfo.IsStatic Property

Gets a value indicating whether this method is static

public override Boolean IsStatic {get;}

See Also

MethodInfo Class | Debugger Namespace


MetadataToken Property

Managed Debugger (by David Srbecky)

MethodInfo.MetadataToken Property

Gets the metadata token associated with this method

public override UInt32 MetadataToken {get;}

See Also

MethodInfo Class | Debugger Namespace


Name Property

Managed Debugger (by David Srbecky)

MethodInfo.Name Property

Gets the name of this method

public override String Name {get;}

See Also

MethodInfo Class | Debugger Namespace


MethodInfo Methods

The methods of the MethodInfo class are listed below. For a complete list of MethodInfo class members, see the MethodInfo Members topic.

Public Static Methods

GetFromName Get a method from a managed type, method name and argument count

Public Instance Methods

AsyncInvoke | Asynchronously invoke the method of an a given object
Invoke | Synchronously invoke the method of an a given object

See Also

MethodInfo Class | Debugger Namespace


MethodInfo.AsyncInvoke Method

Asynchronously invoke the method of an a given object

public Eval AsyncInvoke(
Value objectInstance,
Value[] arguments
);

See Also

MethodInfo Class | Debugger Namespace


MethodInfo.GetFromName Method

Get a method from a managed type, method name and argument count

public static MethodInfo GetFromName(
Process process,
Type type,
String name,
Int32 paramCount
);

See Also

MethodInfo Class | Debugger Namespace


MethodInfo.Invoke Method

Synchronously invoke the method of an a given object

public Value Invoke(
Value objectInstance,
Value[] arguments
);

See Also

MethodInfo Class | Debugger Namespace


Module Class

For a list of all members of this type, see Module Members.

System.Object
MarshalByRefObject
DebuggerObject
Module

public class Module : DebuggerObject, IDisposable

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Module Members | Debugger Namespace


Module Members

Module overview

Public Instance Properties

BaseAdress
CorModule
DirectoryName
Filename
FullPath
IsDynamic
IsInMemory
JMCStatus
OrderOfLoading
Process
SymbolsLoaded
SymReader
Unloaded

Public Instance Methods

ApplyChanges
Dispose

See Also

Module Class | Debugger Namespace


Module Properties

The properties of the Module class are listed below. For a complete list of Module class members, see the Module Members topic.

Public Instance Properties

BaseAdress
CorModule
DirectoryName
Filename
FullPath
IsDynamic
IsInMemory
JMCStatus
OrderOfLoading
Process
SymbolsLoaded
SymReader
Unloaded

See Also

Module Class | Debugger Namespace


BaseAdress Property

Managed Debugger (by David Srbecky)

Module.BaseAdress Property

public UInt64 BaseAdress {get;}

See Also

Module Class | Debugger Namespace


CorModule Property

Managed Debugger (by David Srbecky)

Module.CorModule Property

public ICorDebugModule CorModule {get;}

See Also

Module Class | Debugger Namespace


DirectoryName Property

Managed Debugger (by David Srbecky)

Module.DirectoryName Property

public String DirectoryName {get;}

See Also

Module Class | Debugger Namespace


Filename Property

Managed Debugger (by David Srbecky)

Module.Filename Property

public String Filename {get;}

See Also

Module Class | Debugger Namespace


FullPath Property

Managed Debugger (by David Srbecky)

Module.FullPath Property

public String FullPath {get;}

See Also

Module Class | Debugger Namespace


IsDynamic Property

Managed Debugger (by David Srbecky)

Module.IsDynamic Property

public Boolean IsDynamic {get;}

See Also

Module Class | Debugger Namespace


IsInMemory Property

Managed Debugger (by David Srbecky)

Module.IsInMemory Property

public Boolean IsInMemory {get;}

See Also

Module Class | Debugger Namespace


JMCStatus Property

Managed Debugger (by David Srbecky)

Module.JMCStatus Property

public Boolean JMCStatus {set;}

See Also

Module Class | Debugger Namespace


OrderOfLoading Property

Managed Debugger (by David Srbecky)

Module.OrderOfLoading Property

public Int32 OrderOfLoading {get; set;}

See Also

Module Class | Debugger Namespace


Process Property

Managed Debugger (by David Srbecky)

Module.Process Property

public Process Process {get;}

See Also

Module Class | Debugger Namespace


SymbolsLoaded Property

Managed Debugger (by David Srbecky)

Module.SymbolsLoaded Property

public Boolean SymbolsLoaded {get;}

See Also

Module Class | Debugger Namespace


SymReader Property

Managed Debugger (by David Srbecky)

Module.SymReader Property

public ISymUnmanagedReader SymReader {get;}

See Also

Module Class | Debugger Namespace


Unloaded Property

Managed Debugger (by David Srbecky)

Module.Unloaded Property

public Boolean Unloaded {get;}

See Also

Module Class | Debugger Namespace


Module Methods

The methods of the Module class are listed below. For a complete list of Module class members, see the Module Members topic.

Public Instance Methods

ApplyChanges
Dispose

See Also

Module Class | Debugger Namespace


Module.ApplyChanges Method

public void ApplyChanges(
Byte[] metadata,
Byte[] il
);

See Also

Module Class | Debugger Namespace


Module.Dispose Method

public void Dispose();

Implements

IDisposable.Dispose

See Also

Module Class | Debugger Namespace


ModuleEventArgs Class

For a list of all members of this type, see ModuleEventArgs Members.

System.Object
EventArgs
DebuggerEventArgs
ProcessEventArgs
ModuleEventArgs

public class ModuleEventArgs : ProcessEventArgs

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

ModuleEventArgs Members | Debugger Namespace


ModuleEventArgs Members

ModuleEventArgs overview

Public Instance Constructors

ModuleEventArgs Constructor

Public Instance Properties

Debugger (inherited from DebuggerEventArgs)
Module
Process (inherited from ProcessEventArgs)

See Also

ModuleEventArgs Class | Debugger Namespace


ModuleEventArgs Constructor

public ModuleEventArgs(
Module module
);

See Also

ModuleEventArgs Class | Debugger Namespace


ModuleEventArgs Properties

The properties of the ModuleEventArgs class are listed below. For a complete list of ModuleEventArgs class members, see the ModuleEventArgs Members topic.

Public Instance Properties

Debugger (inherited from DebuggerEventArgs)
Module
Process (inherited from ProcessEventArgs)

See Also

ModuleEventArgs Class | Debugger Namespace


Module Property

Managed Debugger (by David Srbecky)

ModuleEventArgs.Module Property

public Module Module {get;}

See Also

ModuleEventArgs Class | Debugger Namespace


NamedValue Class

NamedValue is a Value which has some name associated with it - eg the name of the field that holds the value.

For a list of all members of this type, see NamedValue Members.

System.Object
MarshalByRefObject
DebuggerObject
Value
NamedValue
ArrayElement
LocalVariable
MemberValue
MethodArgument

public class NamedValue : Value

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

NamedValue Members | Debugger Namespace


NamedValue Members

NamedValue overview

Public Instance Properties

ArrayDimensions (inherited from Value) | Gets the lengths of individual dimensions. eg new object[4,5] returns {4,5};
ArrayLenght (inherited from Value) | Gets the number of elements the array can store. eg new object[4,5] returns 20
ArrayRank (inherited from Value) | Gets the number of dimensions of the array. eg new object[4,5] returns 2
AsString (inherited from Value) | Gets a string representation of the value
HasExpired (inherited from Value) | Returns true if the Value have expired and can not be used anymore
IsArray (inherited from Value) | Returns true if the value is an array
IsInteger (inherited from Value) | Gets a value indicating whether the type is an integer type
IsNull (inherited from Value) | Returns true if the value is null
IsObject (inherited from Value) | Returns true if the value is a class or value type
IsPrimitive (inherited from Value) | Returns true if the value is an primitive type. eg int, bool, string
Name | Gets the name associated with the value
PrimitiveValue (inherited from Value) | Gets or sets the value of a primitive type. If setting of a value fails, NotSupportedException is thrown.
Process (inherited from Value) | The process that owns the value
Type (inherited from Value) | Returns the DebugType of the value

Public Instance Methods

GetArrayElement (inherited from Value) | Overloaded. Returns an element of a single-dimensional array
GetArrayElements (inherited from Value) | Returns all elements in the array
GetMember (inherited from Value) | Get a field or property of an object with a given name.
GetMembers (inherited from Value) | Overloaded. Get all fields and properties of an object.
SetValue (inherited from Value) | Copy the acutal value from some other Value object

Public Instance Events

Changed (inherited from Value) | Occurs when the Value have potentialy changed
Expired (inherited from Value) | Occurs when the Value can not be used anymore

Protected Instance Methods

OnChanged (inherited from Value) | Is called when the value changes
OnExpired (inherited from Value) | Is called when the value expires and can not be used anymore

See Also

NamedValue Class | Debugger Namespace


NamedValue Properties

The properties of the NamedValue class are listed below. For a complete list of NamedValue class members, see the NamedValue Members topic.

Public Instance Properties

ArrayDimensions (inherited from Value) | Gets the lengths of individual dimensions. eg new object[4,5] returns {4,5};
ArrayLenght (inherited from Value) | Gets the number of elements the array can store. eg new object[4,5] returns 20
ArrayRank (inherited from Value) | Gets the number of dimensions of the array. eg new object[4,5] returns 2
AsString (inherited from Value) | Gets a string representation of the value
HasExpired (inherited from Value) | Returns true if the Value have expired and can not be used anymore
IsArray (inherited from Value) | Returns true if the value is an array
IsInteger (inherited from Value) | Gets a value indicating whether the type is an integer type
IsNull (inherited from Value) | Returns true if the value is null
IsObject (inherited from Value) | Returns true if the value is a class or value type
IsPrimitive (inherited from Value) | Returns true if the value is an primitive type. eg int, bool, string
Name | Gets the name associated with the value
PrimitiveValue (inherited from Value) | Gets or sets the value of a primitive type. If setting of a value fails, NotSupportedException is thrown.
Process (inherited from Value) | The process that owns the value
Type (inherited from Value) | Returns the DebugType of the value

See Also

NamedValue Class | Debugger Namespace


Name Property

Managed Debugger (by David Srbecky)

NamedValue.Name Property

Gets the name associated with the value

public String Name {get;}

See Also

NamedValue Class | Debugger Namespace


NamedValueCollection Class

An enumerable collection of values accessible by name.

For a list of all members of this type, see NamedValueCollection Members.

System.Object
MarshalByRefObject
DebuggerObject
NamedValueCollection

public class NamedValueCollection : DebuggerObject, IEnumerable<T>, IEnumerable

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

NamedValueCollection Members | Debugger Namespace


NamedValueCollection Members

NamedValueCollection overview

Public Instance Properties

Count | Gets number of named values contained in the collection
Item | Overloaded. Gets a value by index

See Also

NamedValueCollection Class | Debugger Namespace


NamedValueCollection Properties

The properties of the NamedValueCollection class are listed below. For a complete list of NamedValueCollection class members, see the NamedValueCollection Members topic.

Public Instance Properties

Count | Gets number of named values contained in the collection
Item | Overloaded. Gets a value by index

See Also

NamedValueCollection Class | Debugger Namespace


Count Property

Managed Debugger (by David Srbecky)

NamedValueCollection.Count Property

Gets number of named values contained in the collection

public Int32 Count {get;}

See Also

NamedValueCollection Class | Debugger Namespace


Item Property

Managed Debugger (by David Srbecky)

NamedValueCollection.Item Property

Gets a value by index

Overload List

Gets a value by index

public NamedValue this[Int32] {get;}

Gets a value by its name.

public NamedValue this[String] {get;}

See Also

NamedValueCollection Class | Debugger Namespace


Item Property (Int32)

Managed Debugger (by David Srbecky)

NamedValueCollection.Item Property (Int32)

Gets a value by index

public NamedValue this[
Int32 i
] {get;}

See Also

NamedValueCollection Class | Debugger Namespace | NamedValueCollection.Item Overload List


Item Property (String)

Managed Debugger (by David Srbecky)

NamedValueCollection.Item Property (String)

Gets a value by its name.

public NamedValue this[
String variableName
] {get;}

See Also

NamedValueCollection Class | Debugger Namespace | NamedValueCollection.Item Overload List


NDebugger Class

For a list of all members of this type, see NDebugger Members.

System.Object
MarshalByRefObject
DebuggerObject
NDebugger

public class NDebugger : DebuggerObject

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

NDebugger Members | Debugger Namespace


NDebugger Members

NDebugger overview

Public Instance Constructors

NDebugger Constructor Initializes a new instance of the NDebugger class.

Public Instance Properties

Breakpoints
DebuggeeVersion
MTA2STA
Processes

Public Instance Methods

AddBreakpoint | Overloaded.
ClearBreakpoints |
GetDebuggerVersion | Get the .NET version of the process that called this function
GetProgramVersion | Get the .NET version of a given program - eg. "v1.1.4322"
RemoveBreakpoint |
ResetBreakpoints |
Start |
StartWithoutDebugging |

Public Instance Events

BreakpointAdded |
BreakpointHit |
BreakpointRemoved |
BreakpointStateChanged |
DebuggerTraceMessage | Internal: Used to debug the debugger library.
ProcessExited |
ProcessStarted |

Protected Instance Methods

OnBreakpointAdded
OnBreakpointHit
OnBreakpointRemoved
OnBreakpointStateChanged
OnProcessExited
OnProcessStarted

Protected Internal Instance Methods

OnDebuggerTraceMessage

See Also

NDebugger Class | Debugger Namespace


NDebugger Constructor

Initializes a new instance of the NDebugger class.

public NDebugger();

See Also

NDebugger Class | Debugger Namespace


NDebugger Properties

The properties of the NDebugger class are listed below. For a complete list of NDebugger class members, see the NDebugger Members topic.

Public Instance Properties

Breakpoints
DebuggeeVersion
MTA2STA
Processes

See Also

NDebugger Class | Debugger Namespace


Breakpoints Property

Managed Debugger (by David Srbecky)

NDebugger.Breakpoints Property

public IList<T> Breakpoints {get;}

See Also

NDebugger Class | Debugger Namespace


DebuggeeVersion Property

Managed Debugger (by David Srbecky)

NDebugger.DebuggeeVersion Property

public String DebuggeeVersion {get;}

See Also

NDebugger Class | Debugger Namespace


MTA2STA Property

Managed Debugger (by David Srbecky)

NDebugger.MTA2STA Property

public MTA2STA MTA2STA {get;}

See Also

NDebugger Class | Debugger Namespace


Processes Property

Managed Debugger (by David Srbecky)

NDebugger.Processes Property

public IList<T> Processes {get;}

See Also

NDebugger Class | Debugger Namespace


NDebugger Methods

The methods of the NDebugger class are listed below. For a complete list of NDebugger class members, see the NDebugger Members topic.

Public Instance Methods

AddBreakpoint | Overloaded.
ClearBreakpoints |
GetDebuggerVersion | Get the .NET version of the process that called this function
GetProgramVersion | Get the .NET version of a given program - eg. "v1.1.4322"
RemoveBreakpoint |
ResetBreakpoints |
Start |
StartWithoutDebugging |

Protected Instance Methods

OnBreakpointAdded
OnBreakpointHit
OnBreakpointRemoved
OnBreakpointStateChanged
OnProcessExited
OnProcessStarted

Protected Internal Instance Methods

OnDebuggerTraceMessage

See Also

NDebugger Class | Debugger Namespace


AddBreakpoint Method

Managed Debugger (by David Srbecky)

NDebugger.AddBreakpoint Method

Overload List

public Breakpoint AddBreakpoint(SourcecodeSegment,Boolean);

public Breakpoint AddBreakpoint(String,Int32);

See Also

NDebugger Class | Debugger Namespace


NDebugger.AddBreakpoint Method (SourcecodeSegment, Boolean)

public Breakpoint AddBreakpoint(
SourcecodeSegment segment,
Boolean breakpointEnabled
);

See Also

NDebugger Class | Debugger Namespace | NDebugger.AddBreakpoint Overload List


NDebugger.AddBreakpoint Method (String, Int32)

public Breakpoint AddBreakpoint(
String filename,
Int32 line
);

See Also

NDebugger Class | Debugger Namespace | NDebugger.AddBreakpoint Overload List


NDebugger.ClearBreakpoints Method

public void ClearBreakpoints();

See Also

NDebugger Class | Debugger Namespace


NDebugger.GetDebuggerVersion Method

Get the .NET version of the process that called this function

public string GetDebuggerVersion();

See Also

NDebugger Class | Debugger Namespace


NDebugger.GetProgramVersion Method

Get the .NET version of a given program - eg. "v1.1.4322"

public string GetProgramVersion(
String exeFilename
);

See Also

NDebugger Class | Debugger Namespace


NDebugger.OnBreakpointAdded Method

protected virtual void OnBreakpointAdded(
Breakpoint breakpoint
);

See Also

NDebugger Class | Debugger Namespace


NDebugger.OnBreakpointHit Method

protected virtual void OnBreakpointHit(
Object sender,
BreakpointEventArgs e
);

See Also

NDebugger Class | Debugger Namespace


NDebugger.OnBreakpointRemoved Method

protected virtual void OnBreakpointRemoved(
Breakpoint breakpoint
);

See Also

NDebugger Class | Debugger Namespace


NDebugger.OnBreakpointStateChanged Method

protected virtual void OnBreakpointStateChanged(
Object sender,
BreakpointEventArgs e
);

See Also

NDebugger Class | Debugger Namespace


NDebugger.OnDebuggerTraceMessage Method

protected internal virtual void OnDebuggerTraceMessage(
MessageEventArgs e
);

See Also

NDebugger Class | Debugger Namespace


NDebugger.OnProcessExited Method

protected virtual void OnProcessExited(
Process process
);

See Also

NDebugger Class | Debugger Namespace


NDebugger.OnProcessStarted Method

protected virtual void OnProcessStarted(
Process process
);

See Also

NDebugger Class | Debugger Namespace


NDebugger.RemoveBreakpoint Method

public void RemoveBreakpoint(
Breakpoint breakpoint
);

See Also

NDebugger Class | Debugger Namespace


NDebugger.ResetBreakpoints Method

public void ResetBreakpoints();

See Also

NDebugger Class | Debugger Namespace


NDebugger.Start Method

public Process Start(
String filename,
String workingDirectory,
String arguments
);

See Also

NDebugger Class | Debugger Namespace


NDebugger.StartWithoutDebugging Method

public void StartWithoutDebugging(
ProcessStartInfo psi
);

See Also

NDebugger Class | Debugger Namespace


NDebugger Events

The events of the NDebugger class are listed below. For a complete list of NDebugger class members, see the NDebugger Members topic.

Public Instance Events

BreakpointAdded |
BreakpointHit |
BreakpointRemoved |
BreakpointStateChanged |
DebuggerTraceMessage | Internal: Used to debug the debugger library.
ProcessExited |
ProcessStarted |

See Also

NDebugger Class | Debugger Namespace


NDebugger.BreakpointAdded Event

public event EventHandler<TEventArgs> BreakpointAdded;

See Also

NDebugger Class | Debugger Namespace


NDebugger.BreakpointHit Event

public event EventHandler<TEventArgs> BreakpointHit;

See Also

NDebugger Class | Debugger Namespace


NDebugger.BreakpointRemoved Event

public event EventHandler<TEventArgs> BreakpointRemoved;

See Also

NDebugger Class | Debugger Namespace


NDebugger.BreakpointStateChanged Event

public event EventHandler<TEventArgs> BreakpointStateChanged;

See Also

NDebugger Class | Debugger Namespace


NDebugger.DebuggerTraceMessage Event

Internal: Used to debug the debugger library.

public event EventHandler<TEventArgs> DebuggerTraceMessage;

See Also

NDebugger Class | Debugger Namespace


NDebugger.ProcessExited Event

public event EventHandler<TEventArgs> ProcessExited;

See Also

NDebugger Class | Debugger Namespace


NDebugger.ProcessStarted Event

public event EventHandler<TEventArgs> ProcessStarted;

See Also

NDebugger Class | Debugger Namespace


PausedReason Enumeration

public enum PausedReason

Members

Member Name | Description
EvalComplete |
StepComplete |
Breakpoint |
Break |
ControlCTrap |
Exception |
ForcedBreak |
DebuggerError |
CurrentThreadChanged |
CurrentFunctionChanged |
ExceptionIntercepted |
SetIP |
Other |

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Debugger Namespace


PauseSession Class

Holds information about the state of paused debugger. Expires when when Continue is called on debugger.

For a list of all members of this type, see PauseSession Members.

System.Object
PauseSession

public class PauseSession : IExpirable

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

PauseSession Members | Debugger Namespace


PauseSession Members

PauseSession overview

Public Instance Constructors

PauseSession Constructor

Public Instance Properties

HasExpired
PausedReason

Public Instance Events

Expired

See Also

PauseSession Class | Debugger Namespace


PauseSession Constructor

public PauseSession(
PausedReason pausedReason
);

See Also

PauseSession Class | Debugger Namespace


PauseSession Properties

The properties of the PauseSession class are listed below. For a complete list of PauseSession class members, see the PauseSession Members topic.

Public Instance Properties

HasExpired
PausedReason

See Also

PauseSession Class | Debugger Namespace


HasExpired Property

Managed Debugger (by David Srbecky)

PauseSession.HasExpired Property

public Boolean HasExpired {get;}

Implements

IExpirable.HasExpired

See Also

PauseSession Class | Debugger Namespace


PausedReason Property

Managed Debugger (by David Srbecky)

PauseSession.PausedReason Property

public PausedReason PausedReason {get;}

See Also

PauseSession Class | Debugger Namespace


PauseSession Events

The events of the PauseSession class are listed below. For a complete list of PauseSession class members, see the PauseSession Members topic.

Public Instance Events

Expired

See Also

PauseSession Class | Debugger Namespace


PauseSession.Expired Event

public event EventHandler Expired;

Implements

IExpirable.Expired

See Also

PauseSession Class | Debugger Namespace


Process Class

For a list of all members of this type, see Process Members.

System.Object
MarshalByRefObject
DebuggerObject
Process

public class Process : DebuggerObject, IExpirable

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Process Members | Debugger Namespace


Process Members

Process overview

Public Static Methods

CreateProcess

Public Instance Properties

DebugeeState | Indentification of the state of the debugee. This value changes whenever the state of the debugee significatntly changes
DebuggeeVersion |
Debugger |
Evaluating |
HasExpired |
IsPaused |
IsRunning |
LocalVariables |
Modules |
NextStatement |
PausedReason | The reason why the debugger is paused. Thows an DebuggerException if debugger is not paused.
PauseOnHandledException |
PauseSession | Indentification of the current debugger session. This value changes whenever debugger is continued
SelectedFunction |
SelectedThread |
Threads |

Public Instance Methods

AssertPaused |
AssertRunning |
Break |
Continue |
GetModule |
OnDebuggeeStateChanged |
StartEvaluation |
StepInto |
StepOut |
StepOver |
Terminate |
TraceMessage |
WaitForExit | Waits until the precesses exits.
WaitForPause | Waits until the debugger pauses unless it is already paused. Use PausedReason to find out why it paused.

Public Instance Events

DebuggeeStateChanged |
DebuggingPaused |
DebuggingResumed |
ExceptionThrown |
Expired |
LogMessage | Fired when System.Diagnostics.Trace.WriteLine() is called in debuged process
ModuleLoaded |
ModuleUnloaded |
ThreadStarted |

Protected Instance Methods

OnDebuggingPaused
OnExceptionThrown
OnModuleLoaded
OnModuleUnloaded
OnThreadStarted

Protected Internal Instance Methods

OnLogMessage

See Also

Process Class | Debugger Namespace


Process Properties

The properties of the Process class are listed below. For a complete list of Process class members, see the Process Members topic.

Public Instance Properties

DebugeeState | Indentification of the state of the debugee. This value changes whenever the state of the debugee significatntly changes
DebuggeeVersion |
Debugger |
Evaluating |
HasExpired |
IsPaused |
IsRunning |
LocalVariables |
Modules |
NextStatement |
PausedReason | The reason why the debugger is paused. Thows an DebuggerException if debugger is not paused.
PauseOnHandledException |
PauseSession | Indentification of the current debugger session. This value changes whenever debugger is continued
SelectedFunction |
SelectedThread |
Threads |

See Also

Process Class | Debugger Namespace


DebugeeState Property

Managed Debugger (by David Srbecky)

Process.DebugeeState Property

Indentification of the state of the debugee. This value changes whenever the state of the debugee significatntly changes

public DebugeeState DebugeeState {get;}

See Also

Process Class | Debugger Namespace


DebuggeeVersion Property

Managed Debugger (by David Srbecky)

Process.DebuggeeVersion Property

public String DebuggeeVersion {get;}

See Also

Process Class | Debugger Namespace


Debugger Property

Managed Debugger (by David Srbecky)

Process.Debugger Property

public NDebugger Debugger {get;}

See Also

Process Class | Debugger Namespace


Evaluating Property

Managed Debugger (by David Srbecky)

Process.Evaluating Property

public Boolean Evaluating {get;}

See Also

Process Class | Debugger Namespace


HasExpired Property

Managed Debugger (by David Srbecky)

Process.HasExpired Property

public Boolean HasExpired {get;}

Implements

IExpirable.HasExpired

See Also

Process Class | Debugger Namespace


IsPaused Property

Managed Debugger (by David Srbecky)

Process.IsPaused Property

public Boolean IsPaused {get;}

See Also

Process Class | Debugger Namespace


IsRunning Property

Managed Debugger (by David Srbecky)

Process.IsRunning Property

public Boolean IsRunning {get;}

See Also

Process Class | Debugger Namespace


LocalVariables Property

Managed Debugger (by David Srbecky)

Process.LocalVariables Property

public NamedValueCollection LocalVariables {get;}

See Also

Process Class | Debugger Namespace


Modules Property

Managed Debugger (by David Srbecky)

Process.Modules Property

public IList<T> Modules {get;}

See Also

Process Class | Debugger Namespace


NextStatement Property

Managed Debugger (by David Srbecky)

Process.NextStatement Property

public SourcecodeSegment NextStatement {get;}

See Also

Process Class | Debugger Namespace


PausedReason Property

Managed Debugger (by David Srbecky)

Process.PausedReason Property

The reason why the debugger is paused. Thows an DebuggerException if debugger is not paused.

public PausedReason PausedReason {get;}

See Also

Process Class | Debugger Namespace


PauseOnHandledException Property

Managed Debugger (by David Srbecky)

Process.PauseOnHandledException Property

public Boolean PauseOnHandledException {get; set;}

See Also

Process Class | Debugger Namespace


PauseSession Property

Managed Debugger (by David Srbecky)

Process.PauseSession Property

Indentification of the current debugger session. This value changes whenever debugger is continued

public PauseSession PauseSession {get;}

See Also

Process Class | Debugger Namespace


SelectedFunction Property

Managed Debugger (by David Srbecky)

Process.SelectedFunction Property

public Function SelectedFunction {get;}

See Also

Process Class | Debugger Namespace


SelectedThread Property

Managed Debugger (by David Srbecky)

Process.SelectedThread Property

public Thread SelectedThread {get; set;}

See Also

Process Class | Debugger Namespace


Threads Property

Managed Debugger (by David Srbecky)

Process.Threads Property

public IList<T> Threads {get;}

See Also

Process Class | Debugger Namespace


Process Methods

The methods of the Process class are listed below. For a complete list of Process class members, see the Process Members topic.

Public Static Methods

CreateProcess

Public Instance Methods

AssertPaused |
AssertRunning |
Break |
Continue |
GetModule |
OnDebuggeeStateChanged |
StartEvaluation |
StepInto |
StepOut |
StepOver |
Terminate |
TraceMessage |
WaitForExit | Waits until the precesses exits.
WaitForPause | Waits until the debugger pauses unless it is already paused. Use PausedReason to find out why it paused.

Protected Instance Methods

OnDebuggingPaused
OnExceptionThrown
OnModuleLoaded
OnModuleUnloaded
OnThreadStarted

Protected Internal Instance Methods

OnLogMessage

See Also

Process Class | Debugger Namespace


Process.AssertPaused Method

public void AssertPaused();

See Also

Process Class | Debugger Namespace


Process.AssertRunning Method

public void AssertRunning();

See Also

Process Class | Debugger Namespace


Process.Break Method

public void Break();

See Also

Process Class | Debugger Namespace


Process.Continue Method

public void Continue();

See Also

Process Class | Debugger Namespace


Process.CreateProcess Method

public static Process CreateProcess(
NDebugger debugger,
String filename,
String workingDirectory,
String arguments
);

See Also

Process Class | Debugger Namespace


Process.GetModule Method

public Module GetModule(
String filename
);

See Also

Process Class | Debugger Namespace


Process.OnDebuggeeStateChanged Method

public virtual void OnDebuggeeStateChanged();

See Also

Process Class | Debugger Namespace


Process.OnDebuggingPaused Method

protected virtual void OnDebuggingPaused();

See Also

Process Class | Debugger Namespace


Process.OnExceptionThrown Method

protected virtual void OnExceptionThrown(
ExceptionEventArgs e
);

See Also

Process Class | Debugger Namespace


Process.OnLogMessage Method

protected internal virtual void OnLogMessage(
MessageEventArgs arg
);

See Also

Process Class | Debugger Namespace


Process.OnModuleLoaded Method

protected void OnModuleLoaded(
Module module
);

See Also

Process Class | Debugger Namespace


Process.OnModuleUnloaded Method

protected void OnModuleUnloaded(
Module module
);

See Also

Process Class | Debugger Namespace


Process.OnThreadStarted Method

protected virtual void OnThreadStarted(
Thread thread
);

See Also

Process Class | Debugger Namespace


Process.StartEvaluation Method

public void StartEvaluation();

See Also

Process Class | Debugger Namespace


Process.StepInto Method

public void StepInto();

See Also

Process Class | Debugger Namespace


Process.StepOut Method

public void StepOut();

See Also

Process Class | Debugger Namespace


Process.StepOver Method

public void StepOver();

See Also

Process Class | Debugger Namespace


Process.Terminate Method

public void Terminate();

See Also

Process Class | Debugger Namespace


Process.TraceMessage Method

public void TraceMessage(
String message
);

See Also

Process Class | Debugger Namespace


Process.WaitForExit Method

Waits until the precesses exits.

public void WaitForExit();

See Also

Process Class | Debugger Namespace


Process.WaitForPause Method

Waits until the debugger pauses unless it is already paused. Use PausedReason to find out why it paused.

public void WaitForPause();

See Also

Process Class | Debugger Namespace


Process Events

The events of the Process class are listed below. For a complete list of Process class members, see the Process Members topic.

Public Instance Events

DebuggeeStateChanged |
DebuggingPaused |
DebuggingResumed |
ExceptionThrown |
Expired |
LogMessage | Fired when System.Diagnostics.Trace.WriteLine() is called in debuged process
ModuleLoaded |
ModuleUnloaded |
ThreadStarted |

See Also

Process Class | Debugger Namespace


Process.DebuggeeStateChanged Event

public event EventHandler<TEventArgs> DebuggeeStateChanged;

See Also

Process Class | Debugger Namespace


Process.DebuggingPaused Event

public event EventHandler<TEventArgs> DebuggingPaused;

See Also

Process Class | Debugger Namespace


Process.DebuggingResumed Event

public event EventHandler<TEventArgs> DebuggingResumed;

See Also

Process Class | Debugger Namespace


Process.ExceptionThrown Event

public event EventHandler<TEventArgs> ExceptionThrown;

See Also

Process Class | Debugger Namespace


Process.Expired Event

public event EventHandler Expired;

Implements

IExpirable.Expired

See Also

Process Class | Debugger Namespace


Process.LogMessage Event

Fired when System.Diagnostics.Trace.WriteLine() is called in debuged process

public event EventHandler<TEventArgs> LogMessage;

See Also

Process Class | Debugger Namespace


Process.ModuleLoaded Event

public event EventHandler<TEventArgs> ModuleLoaded;

See Also

Process Class | Debugger Namespace


Process.ModuleUnloaded Event

public event EventHandler<TEventArgs> ModuleUnloaded;

See Also

Process Class | Debugger Namespace


Process.ThreadStarted Event

public event EventHandler<TEventArgs> ThreadStarted;

See Also

Process Class | Debugger Namespace


ProcessEventArgs Class

For a list of all members of this type, see ProcessEventArgs Members.

System.Object
EventArgs
DebuggerEventArgs
ProcessEventArgs
Derived types

public class ProcessEventArgs : DebuggerEventArgs

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

ProcessEventArgs Members | Debugger Namespace


ProcessEventArgs Members

ProcessEventArgs overview

Public Instance Constructors

ProcessEventArgs Constructor

Public Instance Properties

Debugger (inherited from DebuggerEventArgs)
Process

See Also

ProcessEventArgs Class | Debugger Namespace


ProcessEventArgs Constructor

public ProcessEventArgs(
Process process
);

See Also

ProcessEventArgs Class | Debugger Namespace


ProcessEventArgs Properties

The properties of the ProcessEventArgs class are listed below. For a complete list of ProcessEventArgs class members, see the ProcessEventArgs Members topic.

Public Instance Properties

Debugger (inherited from DebuggerEventArgs)
Process

See Also

ProcessEventArgs Class | Debugger Namespace


Process Property

Managed Debugger (by David Srbecky)

ProcessEventArgs.Process Property

public Process Process {get;}

See Also

ProcessEventArgs Class | Debugger Namespace


PropertyInfo Class

Provides information about a property in a class

For a list of all members of this type, see PropertyInfo Members.

System.Object
MarshalByRefObject
DebuggerObject
MemberInfo
PropertyInfo

public class PropertyInfo : MemberInfo

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

PropertyInfo Members | Debugger Namespace


PropertyInfo Members

PropertyInfo overview

Public Instance Properties

DeclaringType (inherited from MemberInfo) | Gets the type that declares this member element
IsPrivate | Gets a value indicating whether this property is private
IsPublic | Gets a value indicating whether this property is public
IsStatic | Gets a value indicating whether this property is static
MetadataToken | Gets the metadata token associated with getter (or setter) of this property
Module (inherited from MemberInfo) | Gets the module in which this member is defined
Name | Gets the name of this property
Process (inherited from MemberInfo) | Gets the process in which the type was loaded

Public Instance Methods

GetGetMethod | Get the get accessor of the property
GetSetMethod | Get the set accessor of the property
GetValue | Overloaded. Get the value of the property using the get accessor
SetValue | Overloaded. Set the value of the property using the set accessor

See Also

PropertyInfo Class | Debugger Namespace


PropertyInfo Properties

The properties of the PropertyInfo class are listed below. For a complete list of PropertyInfo class members, see the PropertyInfo Members topic.

Public Instance Properties

DeclaringType (inherited from MemberInfo) | Gets the type that declares this member element
IsPrivate | Gets a value indicating whether this property is private
IsPublic | Gets a value indicating whether this property is public
IsStatic | Gets a value indicating whether this property is static
MetadataToken | Gets the metadata token associated with getter (or setter) of this property
Module (inherited from MemberInfo) | Gets the module in which this member is defined
Name | Gets the name of this property
Process (inherited from MemberInfo) | Gets the process in which the type was loaded

See Also

PropertyInfo Class | Debugger Namespace


IsPrivate Property

Managed Debugger (by David Srbecky)

PropertyInfo.IsPrivate Property

Gets a value indicating whether this property is private

public override Boolean IsPrivate {get;}

See Also

PropertyInfo Class | Debugger Namespace


IsPublic Property

Managed Debugger (by David Srbecky)

PropertyInfo.IsPublic Property

Gets a value indicating whether this property is public

public override Boolean IsPublic {get;}

See Also

PropertyInfo Class | Debugger Namespace


IsStatic Property

Managed Debugger (by David Srbecky)

PropertyInfo.IsStatic Property

Gets a value indicating whether this property is static

public override Boolean IsStatic {get;}

See Also

PropertyInfo Class | Debugger Namespace


MetadataToken Property

Managed Debugger (by David Srbecky)

PropertyInfo.MetadataToken Property

Gets the metadata token associated with getter (or setter) of this property

public override UInt32 MetadataToken {get;}

See Also

PropertyInfo Class | Debugger Namespace


Name Property

Managed Debugger (by David Srbecky)

PropertyInfo.Name Property

Gets the name of this property

public override String Name {get;}

See Also

PropertyInfo Class | Debugger Namespace


PropertyInfo Methods

The methods of the PropertyInfo class are listed below. For a complete list of PropertyInfo class members, see the PropertyInfo Members topic.

Public Instance Methods

GetGetMethod | Get the get accessor of the property
GetSetMethod | Get the set accessor of the property
GetValue | Overloaded. Get the value of the property using the get accessor
SetValue | Overloaded. Set the value of the property using the set accessor

See Also

PropertyInfo Class | Debugger Namespace


PropertyInfo.GetGetMethod Method

Get the get accessor of the property

public MethodInfo GetGetMethod();

See Also

PropertyInfo Class | Debugger Namespace


PropertyInfo.GetSetMethod Method

Get the set accessor of the property

public MethodInfo GetSetMethod();

See Also

PropertyInfo Class | Debugger Namespace


GetValue Method

Managed Debugger (by David Srbecky)

PropertyInfo.GetValue Method

Get the value of the property using the get accessor

Overload List

Get the value of the property using the get accessor

public MemberValue GetValue(Value);

Get the value of indexer property

public MemberValue GetValue(Value,Value[]);

See Also

PropertyInfo Class | Debugger Namespace


PropertyInfo.GetValue Method (Value)

Get the value of the property using the get accessor

public MemberValue GetValue(
Value objectInstance
);

See Also

PropertyInfo Class | Debugger Namespace | PropertyInfo.GetValue Overload List


PropertyInfo.GetValue Method (Value, Value[])

Get the value of indexer property

public MemberValue GetValue(
Value objectInstance,
Value[] parameters
);

See Also

PropertyInfo Class | Debugger Namespace | PropertyInfo.GetValue Overload List


SetValue Method

Managed Debugger (by David Srbecky)

PropertyInfo.SetValue Method

Set the value of the property using the set accessor

Overload List

Set the value of the property using the set accessor

public Value SetValue(Value,Value);

Set the value of indexer property

public Value SetValue(Value,Value,Value[]);

See Also

PropertyInfo Class | Debugger Namespace


PropertyInfo.SetValue Method (Value, Value)

Set the value of the property using the set accessor

public Value SetValue(
Value objectInstance,
Value newValue
);

See Also

PropertyInfo Class | Debugger Namespace | PropertyInfo.SetValue Overload List


PropertyInfo.SetValue Method (Value, Value, Value[])

Set the value of indexer property

public Value SetValue(
Value objectInstance,
Value newValue,
Value[] parameters
);

See Also

PropertyInfo Class | Debugger Namespace | PropertyInfo.SetValue Overload List


SourcecodeSegment Class

For a list of all members of this type, see SourcecodeSegment Members.

System.Object
SourcecodeSegment

public class SourcecodeSegment

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

SourcecodeSegment Members | Debugger Namespace


SourcecodeSegment Members

SourcecodeSegment overview

Public Instance Constructors

SourcecodeSegment Overloaded. Initializes a new instance of the SourcecodeSegment class.

Public Instance Properties

EndColumn
EndLine
ILEnd
ILOffset
ILStart
ModuleFilename
SourceFilename
SourceFullFilename
StartColumn
StartLine
StepRanges

See Also

SourcecodeSegment Class | Debugger Namespace


SourcecodeSegment Constructor

Overload List

public SourcecodeSegment(String,Int32);

public SourcecodeSegment(String,Int32,Int32,Int32);

public SourcecodeSegment(String,Int32,Int32,Int32,Int32);

See Also

SourcecodeSegment Class | Debugger Namespace


SourcecodeSegment Constructor (String, Int32)

public SourcecodeSegment(
String sourceFilename,
Int32 line
);

See Also

SourcecodeSegment Class | Debugger Namespace | SourcecodeSegment Constructor Overload List


SourcecodeSegment Constructor (String, Int32, Int32, Int32)

public SourcecodeSegment(
String sourceFilename,
Int32 line,
Int32 startColumn,
Int32 endColumn
);

See Also

SourcecodeSegment Class | Debugger Namespace | SourcecodeSegment Constructor Overload List


SourcecodeSegment Constructor (String, Int32, Int32, Int32, Int32)

public SourcecodeSegment(
String sourceFilename,
Int32 startLine,
Int32 endLine,
Int32 startColumn,
Int32 endColumn
);

See Also

SourcecodeSegment Class | Debugger Namespace | SourcecodeSegment Constructor Overload List


SourcecodeSegment Properties

The properties of the SourcecodeSegment class are listed below. For a complete list of SourcecodeSegment class members, see the SourcecodeSegment Members topic.

Public Instance Properties

EndColumn
EndLine
ILEnd
ILOffset
ILStart
ModuleFilename
SourceFilename
SourceFullFilename
StartColumn
StartLine
StepRanges

See Also

SourcecodeSegment Class | Debugger Namespace


EndColumn Property

Managed Debugger (by David Srbecky)

SourcecodeSegment.EndColumn Property

public Int32 EndColumn {get; set;}

See Also

SourcecodeSegment Class | Debugger Namespace


EndLine Property

Managed Debugger (by David Srbecky)

SourcecodeSegment.EndLine Property

public Int32 EndLine {get; set;}

See Also

SourcecodeSegment Class | Debugger Namespace


ILEnd Property

Managed Debugger (by David Srbecky)

SourcecodeSegment.ILEnd Property

public Int32 ILEnd {get; set;}

See Also

SourcecodeSegment Class | Debugger Namespace


ILOffset Property

Managed Debugger (by David Srbecky)

SourcecodeSegment.ILOffset Property

public Int32 ILOffset {get; set;}

See Also

SourcecodeSegment Class | Debugger Namespace


ILStart Property

Managed Debugger (by David Srbecky)

SourcecodeSegment.ILStart Property

public Int32 ILStart {get; set;}

See Also

SourcecodeSegment Class | Debugger Namespace


ModuleFilename Property

Managed Debugger (by David Srbecky)

SourcecodeSegment.ModuleFilename Property

public String ModuleFilename {get; set;}

See Also

SourcecodeSegment Class | Debugger Namespace


SourceFilename Property

Managed Debugger (by David Srbecky)

SourcecodeSegment.SourceFilename Property

public String SourceFilename {get;}

See Also

SourcecodeSegment Class | Debugger Namespace


SourceFullFilename Property

Managed Debugger (by David Srbecky)

SourcecodeSegment.SourceFullFilename Property

public String SourceFullFilename {get; set;}

See Also

SourcecodeSegment Class | Debugger Namespace


StartColumn Property

Managed Debugger (by David Srbecky)

SourcecodeSegment.StartColumn Property

public Int32 StartColumn {get; set;}

See Also

SourcecodeSegment Class | Debugger Namespace


StartLine Property

Managed Debugger (by David Srbecky)

SourcecodeSegment.StartLine Property

public Int32 StartLine {get; set;}

See Also

SourcecodeSegment Class | Debugger Namespace


StepRanges Property

Managed Debugger (by David Srbecky)

SourcecodeSegment.StepRanges Property

public Int32[] StepRanges {get; set;}

See Also

SourcecodeSegment Class | Debugger Namespace


Stepper Class

For a list of all members of this type, see Stepper Members.

System.Object
Stepper

public class Stepper

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Stepper Members | Debugger Namespace


Stepper Members

Stepper overview

Public Instance Constructors

Stepper Overloaded. Initializes a new instance of the Stepper class.

Public Instance Properties

Function
JustMyCode
Name
Operation
PauseWhenComplete
Process

Public Instance Methods

StepIn
StepOut
StepOver
ToString

Public Instance Events

StepComplete

Protected Internal Instance Methods

OnStepComplete

See Also

Stepper Class | Debugger Namespace


Stepper Constructor

Overload List

public Stepper(Function);

public Stepper(Function,String);

See Also

Stepper Class | Debugger Namespace


Stepper Constructor (Function, String)

public Stepper(
Function function,
String name
);

See Also

Stepper Class | Debugger Namespace | Stepper Constructor Overload List


Stepper Constructor (Function)

public Stepper(
Function function
);

See Also

Stepper Class | Debugger Namespace | Stepper Constructor Overload List


Stepper Properties

The properties of the Stepper class are listed below. For a complete list of Stepper class members, see the Stepper Members topic.

Public Instance Properties

Function
JustMyCode
Name
Operation
PauseWhenComplete
Process

See Also

Stepper Class | Debugger Namespace


Function Property

Managed Debugger (by David Srbecky)

Stepper.Function Property

public Function Function {get;}

See Also

Stepper Class | Debugger Namespace


JustMyCode Property

Managed Debugger (by David Srbecky)

Stepper.JustMyCode Property

public Boolean JustMyCode {set;}

See Also

Stepper Class | Debugger Namespace


Name Property

Managed Debugger (by David Srbecky)

Stepper.Name Property

public String Name {get;}

See Also

Stepper Class | Debugger Namespace


Operation Property

Managed Debugger (by David Srbecky)

Stepper.Operation Property

public Stepper.StepperOperation Operation {get;}

See Also

Stepper Class | Debugger Namespace


PauseWhenComplete Property

Managed Debugger (by David Srbecky)

Stepper.PauseWhenComplete Property

public Boolean PauseWhenComplete {get; set;}

See Also

Stepper Class | Debugger Namespace


Process Property

Managed Debugger (by David Srbecky)

Stepper.Process Property

public Process Process {get;}

See Also

Stepper Class | Debugger Namespace


Stepper Methods

The methods of the Stepper class are listed below. For a complete list of Stepper class members, see the Stepper Members topic.

Public Instance Methods

StepIn
StepOut
StepOver
ToString

Protected Internal Instance Methods

OnStepComplete

See Also

Stepper Class | Debugger Namespace


Stepper.OnStepComplete Method

protected internal virtual void OnStepComplete();

See Also

Stepper Class | Debugger Namespace


Stepper.StepIn Method

public void StepIn(
Int32[] ranges
);

See Also

Stepper Class | Debugger Namespace


Stepper.StepOut Method

public void StepOut();

See Also

Stepper Class | Debugger Namespace


Stepper.StepOver Method

public void StepOver(
Int32[] ranges
);

See Also

Stepper Class | Debugger Namespace


Stepper.ToString Method

public override string ToString();

See Also

Stepper Class | Debugger Namespace


Stepper Events

The events of the Stepper class are listed below. For a complete list of Stepper class members, see the Stepper Members topic.

Public Instance Events

StepComplete

See Also

Stepper Class | Debugger Namespace


Stepper.StepComplete Event

public event EventHandler<TEventArgs> StepComplete;

See Also

Stepper Class | Debugger Namespace


Stepper.StepperOperation Enumeration

public enum Stepper.StepperOperation

Members

Member Name | Description
Idle |
StepIn |
StepOver |
StepOut |

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Debugger Namespace


StepperEventArgs Class

For a list of all members of this type, see StepperEventArgs Members.

System.Object
EventArgs
DebuggerEventArgs
ProcessEventArgs
StepperEventArgs

public class StepperEventArgs : ProcessEventArgs

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

StepperEventArgs Members | Debugger Namespace


StepperEventArgs Members

StepperEventArgs overview

Public Instance Constructors

StepperEventArgs Constructor

Public Instance Properties

Debugger (inherited from DebuggerEventArgs)
Process (inherited from ProcessEventArgs)
Stepper

See Also

StepperEventArgs Class | Debugger Namespace


StepperEventArgs Constructor

public StepperEventArgs(
Stepper stepper
);

See Also

StepperEventArgs Class | Debugger Namespace


StepperEventArgs Properties

The properties of the StepperEventArgs class are listed below. For a complete list of StepperEventArgs class members, see the StepperEventArgs Members topic.

Public Instance Properties

Debugger (inherited from DebuggerEventArgs)
Process (inherited from ProcessEventArgs)
Stepper

See Also

StepperEventArgs Class | Debugger Namespace


Stepper Property

Managed Debugger (by David Srbecky)

StepperEventArgs.Stepper Property

public Stepper Stepper {get;}

See Also

StepperEventArgs Class | Debugger Namespace


Thread Class

For a list of all members of this type, see Thread Members.

System.Object
MarshalByRefObject
DebuggerObject
Thread

public class Thread : DebuggerObject, IExpirable

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Thread Members | Debugger Namespace


Thread Members

Thread overview

Public Instance Properties

Callstack |
CorThread |
CurrentException |
CurrentExceptionType |
FirstFunction | Returns the first function that was called on thread
HasExpired |
ID |
IsAtSafePoint |
IsLastFunctionNative |
LastFunction | Returns the most recent function on callstack. Returns null if callstack is empty.
LastFunctionWithLoadedSymbols |
Name |
Priority |
Process |
RuntimeValue |
SelectedFunction |
Suspended |

Public Instance Methods

InterceptCurrentException
ToString

Public Instance Events

Expired
NativeThreadExited
StateChanged

Protected Instance Methods

OnExpired
OnNativeThreadExited
OnStateChanged

See Also

Thread Class | Debugger Namespace


Thread Properties

The properties of the Thread class are listed below. For a complete list of Thread class members, see the Thread Members topic.

Public Instance Properties

Callstack |
CorThread |
CurrentException |
CurrentExceptionType |
FirstFunction | Returns the first function that was called on thread
HasExpired |
ID |
IsAtSafePoint |
IsLastFunctionNative |
LastFunction | Returns the most recent function on callstack. Returns null if callstack is empty.
LastFunctionWithLoadedSymbols |
Name |
Priority |
Process |
RuntimeValue |
SelectedFunction |
Suspended |

See Also

Thread Class | Debugger Namespace


Callstack Property

Managed Debugger (by David Srbecky)

Thread.Callstack Property

public IEnumerable<T> Callstack {get;}

See Also

Thread Class | Debugger Namespace


CorThread Property

Managed Debugger (by David Srbecky)

Thread.CorThread Property

public ICorDebugThread CorThread {get;}

See Also

Thread Class | Debugger Namespace


CurrentException Property

Managed Debugger (by David Srbecky)

Thread.CurrentException Property

public Exception CurrentException {get;}

See Also

Thread Class | Debugger Namespace


CurrentExceptionType Property

Managed Debugger (by David Srbecky)

Thread.CurrentExceptionType Property

public ExceptionType CurrentExceptionType {get; set;}

See Also

Thread Class | Debugger Namespace


FirstFunction Property

Managed Debugger (by David Srbecky)

Thread.FirstFunction Property

Returns the first function that was called on thread

public Function FirstFunction {get;}

See Also

Thread Class | Debugger Namespace


HasExpired Property

Managed Debugger (by David Srbecky)

Thread.HasExpired Property

public Boolean HasExpired {get;}

Implements

IExpirable.HasExpired

See Also

Thread Class | Debugger Namespace


ID Property

Managed Debugger (by David Srbecky)

Thread.ID Property

public UInt32 ID {get;}

See Also

Thread Class | Debugger Namespace


IsAtSafePoint Property

Managed Debugger (by David Srbecky)

Thread.IsAtSafePoint Property

public Boolean IsAtSafePoint {get;}

See Also

Thread Class | Debugger Namespace


IsLastFunctionNative Property

Managed Debugger (by David Srbecky)

Thread.IsLastFunctionNative Property

public Boolean IsLastFunctionNative {get;}

See Also

Thread Class | Debugger Namespace


LastFunction Property

Managed Debugger (by David Srbecky)

Thread.LastFunction Property

Returns the most recent function on callstack. Returns null if callstack is empty.

public Function LastFunction {get;}

See Also

Thread Class | Debugger Namespace


LastFunctionWithLoadedSymbols Property

Managed Debugger (by David Srbecky)

Thread.LastFunctionWithLoadedSymbols Property

public Function LastFunctionWithLoadedSymbols {get;}

See Also

Thread Class | Debugger Namespace


Name Property

Managed Debugger (by David Srbecky)

Thread.Name Property

public String Name {get;}

See Also

Thread Class | Debugger Namespace


Priority Property

Managed Debugger (by David Srbecky)

Thread.Priority Property

public ThreadPriority Priority {get;}

See Also

Thread Class | Debugger Namespace


Process Property

Managed Debugger (by David Srbecky)

Thread.Process Property

public Process Process {get;}

See Also

Thread Class | Debugger Namespace


RuntimeValue Property

Managed Debugger (by David Srbecky)

Thread.RuntimeValue Property

public Value RuntimeValue {get;}

See Also

Thread Class | Debugger Namespace


SelectedFunction Property

Managed Debugger (by David Srbecky)

Thread.SelectedFunction Property

public Function SelectedFunction {get; set;}

See Also

Thread Class | Debugger Namespace


Suspended Property

Managed Debugger (by David Srbecky)

Thread.Suspended Property

public Boolean Suspended {get; set;}

See Also

Thread Class | Debugger Namespace


Thread Methods

The methods of the Thread class are listed below. For a complete list of Thread class members, see the Thread Members topic.

Public Instance Methods

InterceptCurrentException
ToString

Protected Instance Methods

OnExpired
OnNativeThreadExited
OnStateChanged

See Also

Thread Class | Debugger Namespace


Thread.InterceptCurrentException Method

public bool InterceptCurrentException();

See Also

Thread Class | Debugger Namespace


Thread.OnExpired Method

protected virtual void OnExpired(
EventArgs e
);

See Also

Thread Class | Debugger Namespace


Thread.OnNativeThreadExited Method

protected virtual void OnNativeThreadExited(
ThreadEventArgs e
);

See Also

Thread Class | Debugger Namespace


Thread.OnStateChanged Method

protected void OnStateChanged();

See Also

Thread Class | Debugger Namespace


Thread.ToString Method

public override string ToString();

See Also

Thread Class | Debugger Namespace


Thread Events

The events of the Thread class are listed below. For a complete list of Thread class members, see the Thread Members topic.

Public Instance Events

Expired
NativeThreadExited
StateChanged

See Also

Thread Class | Debugger Namespace


Thread.Expired Event

public event EventHandler Expired;

Implements

IExpirable.Expired

See Also

Thread Class | Debugger Namespace


Thread.NativeThreadExited Event

public event EventHandler<TEventArgs> NativeThreadExited;

See Also

Thread Class | Debugger Namespace


Thread.StateChanged Event

public event EventHandler<TEventArgs> StateChanged;

See Also

Thread Class | Debugger Namespace


ThreadEventArgs Class

For a list of all members of this type, see ThreadEventArgs Members.

System.Object
EventArgs
DebuggerEventArgs
ProcessEventArgs
ThreadEventArgs

public class ThreadEventArgs : ProcessEventArgs

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

ThreadEventArgs Members | Debugger Namespace


ThreadEventArgs Members

ThreadEventArgs overview

Public Instance Constructors

ThreadEventArgs Constructor

Public Instance Properties

Debugger (inherited from DebuggerEventArgs)
Process (inherited from ProcessEventArgs)
Thread

See Also

ThreadEventArgs Class | Debugger Namespace


ThreadEventArgs Constructor

public ThreadEventArgs(
Thread thread
);

See Also

ThreadEventArgs Class | Debugger Namespace


ThreadEventArgs Properties

The properties of the ThreadEventArgs class are listed below. For a complete list of ThreadEventArgs class members, see the ThreadEventArgs Members topic.

Public Instance Properties

Debugger (inherited from DebuggerEventArgs)
Process (inherited from ProcessEventArgs)
Thread

See Also

ThreadEventArgs Class | Debugger Namespace


Thread Property

Managed Debugger (by David Srbecky)

ThreadEventArgs.Thread Property

public Thread Thread {get;}

See Also

ThreadEventArgs Class | Debugger Namespace


Value Class

Provides more specific access

For a list of all members of this type, see Value Members.

System.Object
MarshalByRefObject
DebuggerObject
Value
NamedValue

public class Value : DebuggerObject, IExpirable, IMutable

Remarks

Expiration: Once value expires it can not be used anymore. Expiration is permanet - once value expires it stays expired. Value expires when any object specified in constructor expires or when process exits.

Mutation: As long as any dependecy does not mutate the last obteined value is still considered up to date. (If continue is called and internal value is neutred, new copy will be obatined)

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

Value Members | Debugger Namespace


Value Members

Value overview

Public Instance Properties

ArrayDimensions | Gets the lengths of individual dimensions. eg new object[4,5] returns {4,5};
ArrayLenght | Gets the number of elements the array can store. eg new object[4,5] returns 20
ArrayRank | Gets the number of dimensions of the array. eg new object[4,5] returns 2
AsString | Gets a string representation of the value
HasExpired | Returns true if the Value have expired and can not be used anymore
IsArray | Returns true if the value is an array
IsInteger | Gets a value indicating whether the type is an integer type
IsNull | Returns true if the value is null
IsObject | Returns true if the value is a class or value type
IsPrimitive | Returns true if the value is an primitive type. eg int, bool, string
PrimitiveValue | Gets or sets the value of a primitive type. If setting of a value fails, NotSupportedException is thrown.
Process | The process that owns the value
Type | Returns the DebugType of the value

Public Instance Methods

GetArrayElement | Overloaded. Returns an element of a single-dimensional array
GetArrayElements | Returns all elements in the array
GetMember | Get a field or property of an object with a given name.
GetMembers | Overloaded. Get all fields and properties of an object.
SetValue | Copy the acutal value from some other Value object

Public Instance Events

Changed | Occurs when the Value have potentialy changed
Expired | Occurs when the Value can not be used anymore

Protected Instance Methods

OnChanged | Is called when the value changes
OnExpired | Is called when the value expires and can not be used anymore

See Also

Value Class | Debugger Namespace


Value Properties

The properties of the Value class are listed below. For a complete list of Value class members, see the Value Members topic.

Public Instance Properties

ArrayDimensions | Gets the lengths of individual dimensions. eg new object[4,5] returns {4,5};
ArrayLenght | Gets the number of elements the array can store. eg new object[4,5] returns 20
ArrayRank | Gets the number of dimensions of the array. eg new object[4,5] returns 2
AsString | Gets a string representation of the value
HasExpired | Returns true if the Value have expired and can not be used anymore
IsArray | Returns true if the value is an array
IsInteger | Gets a value indicating whether the type is an integer type
IsNull | Returns true if the value is null
IsObject | Returns true if the value is a class or value type
IsPrimitive | Returns true if the value is an primitive type. eg int, bool, string
PrimitiveValue | Gets or sets the value of a primitive type. If setting of a value fails, NotSupportedException is thrown.
Process | The process that owns the value
Type | Returns the DebugType of the value

See Also

Value Class | Debugger Namespace


ArrayDimensions Property

Managed Debugger (by David Srbecky)

Value.ArrayDimensions Property

Gets the lengths of individual dimensions. eg new object[4,5] returns {4,5};

public UInt32[] ArrayDimensions {get;}

See Also

Value Class | Debugger Namespace


ArrayLenght Property

Managed Debugger (by David Srbecky)

Value.ArrayLenght Property

Gets the number of elements the array can store. eg new object[4,5] returns 20

public UInt32 ArrayLenght {get;}

See Also

Value Class | Debugger Namespace


ArrayRank Property

Managed Debugger (by David Srbecky)

Value.ArrayRank Property

Gets the number of dimensions of the array. eg new object[4,5] returns 2

public UInt32 ArrayRank {get;}

See Also

Value Class | Debugger Namespace


AsString Property

Managed Debugger (by David Srbecky)

Value.AsString Property

Gets a string representation of the value

public String AsString {get;}

See Also

Value Class | Debugger Namespace


HasExpired Property

Managed Debugger (by David Srbecky)

Value.HasExpired Property

Returns true if the Value have expired and can not be used anymore

public Boolean HasExpired {get;}

Implements

IExpirable.HasExpired

See Also

Value Class | Debugger Namespace


IsArray Property

Managed Debugger (by David Srbecky)

Value.IsArray Property

Returns true if the value is an array

public Boolean IsArray {get;}

See Also

Value Class | Debugger Namespace


IsInteger Property

Managed Debugger (by David Srbecky)

Value.IsInteger Property

Gets a value indicating whether the type is an integer type

public Boolean IsInteger {get;}

See Also

Value Class | Debugger Namespace


IsNull Property

Managed Debugger (by David Srbecky)

Value.IsNull Property

Returns true if the value is null

public Boolean IsNull {get;}

See Also

Value Class | Debugger Namespace


IsObject Property

Managed Debugger (by David Srbecky)

Value.IsObject Property

Returns true if the value is a class or value type

public Boolean IsObject {get;}

See Also

Value Class | Debugger Namespace


IsPrimitive Property

Managed Debugger (by David Srbecky)

Value.IsPrimitive Property

Returns true if the value is an primitive type. eg int, bool, string

public Boolean IsPrimitive {get;}

See Also

Value Class | Debugger Namespace


PrimitiveValue Property

Managed Debugger (by David Srbecky)

Value.PrimitiveValue Property

Gets or sets the value of a primitive type. If setting of a value fails, NotSupportedException is thrown.

public Object PrimitiveValue {get; set;}

See Also

Value Class | Debugger Namespace


Process Property

Managed Debugger (by David Srbecky)

Value.Process Property

The process that owns the value

public Process Process {get;}

See Also

Value Class | Debugger Namespace


Type Property

Managed Debugger (by David Srbecky)

Value.Type Property

Returns the DebugType of the value

public DebugType Type {get;}

See Also

Value Class | Debugger Namespace


Value Methods

The methods of the Value class are listed below. For a complete list of Value class members, see the Value Members topic.

Public Instance Methods

GetArrayElement | Overloaded. Returns an element of a single-dimensional array
GetArrayElements | Returns all elements in the array
GetMember | Get a field or property of an object with a given name.
GetMembers | Overloaded. Get all fields and properties of an object.
SetValue | Copy the acutal value from some other Value object

Protected Instance Methods

OnChanged | Is called when the value changes
OnExpired | Is called when the value expires and can not be used anymore

See Also

Value Class | Debugger Namespace


GetArrayElement Method

Managed Debugger (by David Srbecky)

Value.GetArrayElement Method

Returns an element of a single-dimensional array

Overload List

Returns an element of a single-dimensional array

public ArrayElement GetArrayElement(UInt32);

Returns an element of an array

public ArrayElement GetArrayElement(UInt32[]);

See Also

Value Class | Debugger Namespace


Value.GetArrayElement Method (UInt32)

Returns an element of a single-dimensional array

public ArrayElement GetArrayElement(
UInt32 index
);

See Also

Value Class | Debugger Namespace | Value.GetArrayElement Overload List


Value.GetArrayElement Method (UInt32[])

Returns an element of an array

public ArrayElement GetArrayElement(
UInt32[] elementIndices
);

See Also

Value Class | Debugger Namespace | Value.GetArrayElement Overload List


Value.GetArrayElements Method

Returns all elements in the array

public NamedValueCollection GetArrayElements();

See Also

Value Class | Debugger Namespace


Value.GetMember Method

Get a field or property of an object with a given name.

public NamedValue GetMember(
String name
);

See Also

Value Class | Debugger Namespace


GetMembers Method

Managed Debugger (by David Srbecky)

Value.GetMembers Method

Get all fields and properties of an object.

Overload List

Get all fields and properties of an object.

public NamedValueCollection GetMembers();

Get fields and properties of an object which are defined by a given type.

public NamedValueCollection GetMembers(DebugType,BindingFlags);

See Also

Value Class | Debugger Namespace


Value.GetMembers Method ()

Get all fields and properties of an object.

public NamedValueCollection GetMembers();

See Also

Value Class | Debugger Namespace | Value.GetMembers Overload List


Value.GetMembers Method (DebugType, BindingFlags)

Get fields and properties of an object which are defined by a given type.

public NamedValueCollection GetMembers(
DebugType type,
BindingFlags bindingFlags
);

Parameters

type
Limit to type, null for all types
bindingFlags
Get only members with certain flags

See Also

Value Class | Debugger Namespace | Value.GetMembers Overload List


Value.OnChanged Method

Is called when the value changes

protected virtual void OnChanged(
ProcessEventArgs e
);

See Also

Value Class | Debugger Namespace


Value.OnExpired Method

Is called when the value expires and can not be used anymore

protected virtual void OnExpired(
EventArgs e
);

See Also

Value Class | Debugger Namespace


Value.SetValue Method

Copy the acutal value from some other Value object

public bool SetValue(
Value newValue
);

See Also

Value Class | Debugger Namespace


Value Events

The events of the Value class are listed below. For a complete list of Value class members, see the Value Members topic.

Public Instance Events

Changed | Occurs when the Value have potentialy changed
Expired | Occurs when the Value can not be used anymore

See Also

Value Class | Debugger Namespace


Value.Changed Event

Occurs when the Value have potentialy changed

public event EventHandler<TEventArgs> Changed;

Implements

IMutable.Changed

See Also

Value Class | Debugger Namespace


Value.Expired Event

Occurs when the Value can not be used anymore

public event EventHandler Expired;

Implements

IExpirable.Expired

See Also

Value Class | Debugger Namespace


ValueEventArgs Class

Provides data for events related to Value class

For a list of all members of this type, see ValueEventArgs Members.

System.Object
EventArgs
DebuggerEventArgs
ProcessEventArgs
ValueEventArgs

public class ValueEventArgs : ProcessEventArgs

Requirements

Namespace: Debugger

Assembly: Debugger.Core (in Debugger.Core.dll)

See Also

ValueEventArgs Members | Debugger Namespace


ValueEventArgs Members

ValueEventArgs overview

Public Instance Constructors

ValueEventArgs Constructor Initializes a new instance of the class

Public Instance Properties

Debugger (inherited from DebuggerEventArgs) |
Process (inherited from ProcessEventArgs) |
Value | The value that caused the event

See Also

ValueEventArgs Class | Debugger Namespace


ValueEventArgs Constructor

Initializes a new instance of the class

public ValueEventArgs(
Value val
);

See Also

ValueEventArgs Class | Debugger Namespace


ValueEventArgs Properties

The properties of the ValueEventArgs class are listed below. For a complete list of ValueEventArgs class members, see the ValueEventArgs Members topic.

Public Instance Properties

Debugger (inherited from DebuggerEventArgs) |
Process (inherited from ProcessEventArgs) |
Value | The value that caused the event

See Also

ValueEventArgs Class | Debugger Namespace


Value Property

Managed Debugger (by David Srbecky)

ValueEventArgs.Value Property

The value that caused the event

public Value Value {get;}

See Also

ValueEventArgs Class | Debugger Namespace


DebuggerObject Hierarchy

System.Object
MarshalByRefObject
DebuggerObject
Breakpoint
DebugType
Eval
Exception
Function
MemberInfo
Module
NamedValueCollection
NDebugger
Process
Thread
Value

See Also

DebuggerObject Class | DebuggerObject Members | Debugger Namespace


ProcessEventArgs Hierarchy

System.Object
EventArgs
DebuggerEventArgs
ProcessEventArgs
EvalEventArgs
ExceptionEventArgs
MessageEventArgs
ModuleEventArgs
StepperEventArgs
ThreadEventArgs
ValueEventArgs

See Also

ProcessEventArgs Class | ProcessEventArgs Members | Debugger Namespace


DebuggerHierarchy

Managed Debugger (by David Srbecky)

Debugger Hierarchy

System.Object
Debugger.DebugeeState ---- Debugger.IExpirable, Debugger.IMutable
Debugger.IExpirable
Debugger.IMutable
Debugger.PauseSession ---- Debugger.IExpirable
Debugger.SourcecodeSegment
Debugger.Stepper
System.EventArgs
Debugger.DebuggerEventArgs
Debugger.BreakpointEventArgs
Debugger.ProcessEventArgs
Debugger.EvalEventArgs
Debugger.ExceptionEventArgs
Debugger.MessageEventArgs
Debugger.ModuleEventArgs
Debugger.StepperEventArgs
Debugger.ThreadEventArgs
Debugger.ValueEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
Debugger.DebuggerException
Debugger.CannotGetValueException
System.MarshalByRefObject
Debugger.DebuggerObject
Debugger.Breakpoint
Debugger.DebugType
Debugger.Eval
Debugger.Exception
Debugger.Function ---- Debugger.IExpirable
Debugger.MemberInfo
Debugger.FieldInfo
Debugger.MethodInfo
Debugger.PropertyInfo
Debugger.Module ---- System.IDisposable
Debugger.NamedValueCollection ---- System.Collections.Generic.IEnumerable`1, System.Collections.IEnumerable
Debugger.NDebugger
Debugger.Process ---- Debugger.IExpirable
Debugger.Thread ---- Debugger.IExpirable
Debugger.Value ---- Debugger.IExpirable, Debugger.IMutable
Debugger.NamedValue
Debugger.ArrayElement
Debugger.LocalVariable
Debugger.MemberValue
Debugger.MethodArgument
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Debugger.BindingFlags
Debugger.EvalState
Debugger.ExceptionType
Debugger.PausedReason
Debugger.Stepper.StepperOperation

See Also

Debugger Namespace